Issues creating a custom map extent

432
3
06-10-2022 10:24 AM
Labels (1)
KorinMiles
New Contributor II

I have found when I add a map and set the custom extent of the map, then turn off all the Tools, I am no longer able to then change the extent of the map. Even after turning Tools back on, the map has to be totally deleted and added back to the page to update the extent. I've also noticed that when I add a map to experience builder, if I then go and make changes to the map, like adding additional layers, those additional layers to not get added to the data I can access, through the map, in all the other widgets. I had to delete the map out of my data and add it again and then all the new layers were available. 

0 Kudos
3 Replies
TonghuiMing
Esri Regular Contributor

@KorinMiles Are you still seeing this issue? Tried in the latest AGOL environment and I cannot reproduce that -

TonghuiMing_0-1657589835368.png

 

0 Kudos
KorinMiles
New Contributor II

I am not still seeing this issue. But I am having another issue with custom extents in my maps. If I add the same web map multiple times with different extents, if a selection is made and left in one map, it changes all of my custom extents in my other maps. I found this to only happen when my maps are on different pages in Experience Builder, but not when they are on the same page. Thanks

0 Kudos
TonghuiMing
Esri Regular Contributor

Unfortunately, I tried a few times but have not seen this. It might sound like a message action of record selection change had been configured somewhere that caused the extent change.

It would be easier to reach out to Esri Support or provide a sample app with the reproducible steps if the problem persists for you.

0 Kudos