Hide a layer in the Map Layers Widget in Experience Builder

4353
21
Jump to solution
02-02-2022 11:00 AM
sroberts_uuF21
New Contributor II

Hello! 

I am building out a simple mapping application using Experience Builder. I have a layer within my web map that I am using for arcade expressions within my popups but I don't want the layer showing up in my legend or layer list. In the past, when using map viewer classic and WAB, this process of hiding the layer in my layer list was pretty straightforward but it doesn't seem to be a functionality within Experience Builder/the new version of Map Viewer. 

I have figured out how to hide the layer from my legend but still no luck with the layer list. It seems like such a simple functionality, I would be surprised for it not to be supported yet. 

Any assistance is much appreciated!

Thanks!

Thanks1

1 Solution

Accepted Solutions
TonghuiMing
Esri Regular Contributor

In the latest AGOL February release, the Map Layers widget has supported a new feature - "Customize layers":

TonghuiMing_0-1678069165536.png

This will help fulfill this specific case.

View solution in original post

21 Replies
TonghuiMing
Esri Regular Contributor

@sroberts_uuF21 In ExB, you could try the following steps inside the Map Layers widget:

TonghuiMing_0-1644482460186.png

 

0 Kudos
sroberts_uuF21
New Contributor II

Thank you for the response @TonghuiMing !

Unfortunately this does not solve our problem. The above suggested solution allows users to be able to turn the layer on and off in the app. We dont want users to even be able to see the layer in the map layers widget as an option. In WebAppBuilder there is an option to hide layers from the layer list widget but this does not seem like an option in Experience Builder. 

0 Kudos
TonghuiMing
Esri Regular Contributor

@sroberts_uuF21 I see. Thanks for clarifying it. We will take a look.

0 Kudos
ReinhardtBotha
New Contributor III

Subscribed to the thread, I'm also interested in being able to do this.

@sroberts_uuF21 how were you able to hide layers from the legend widget?

0 Kudos
JoshuaReyling
New Contributor II

@ReinhardtBotha , 

To hide legend entries in experience builder, simply turn off the legend visibility in the layer properties within Map Viewer. The setting will persist in Experience builder.

JoshuaReyling_0-1649095312525.png

Hope that helps.

 

ReinhardtBotha
New Contributor III

Thanks so much for that @JoshuaReyling!

0 Kudos
by Anonymous User
Not applicable

Yes 100% agree, this problem should be fixed quickly.

0 Kudos
MarkEastwood
Occasional Contributor II

Agreed, we also need to be able to remove layers from a layer list for the same reasons @sroberts_uuF21 mentioned above. 

0 Kudos
TonghuiMing
Esri Regular Contributor

In the latest AGOL February release, the Map Layers widget has supported a new feature - "Customize layers":

TonghuiMing_0-1678069165536.png

This will help fulfill this specific case.