Getting javascript error "s.getCurrentQueryParams is not a function" after adding WebMap

3728
17
Jump to solution
12-29-2021 05:11 AM
Ashok
by
New Contributor III

Dear all,

I just started using Experience Builder latest version 1.6.

I connected with my ArcGIS Enterprise Portal account and I am creating one sample application.

I have selected launch pad theme, and added a Webmap from my ArcGIS Portal. After adding webmap , if I try to add any widgets or if I tried to set Map widget style --> I am getting the following error 

"s.getCurrentQueryParams is not a function"

For your understanding attaching the error screenshot here.

MicrosoftTeams-image.png

 

 

 

 

 

 

 

Please help on the issue.

Thanks,

Ashok

0 Kudos
17 Replies
AndrewVentham
New Contributor III

I'm getting this error both in ArcGIS Enterprise 10.9.1 and the dev builder 1.7

0 Kudos
TonghuiMing
Esri Regular Contributor

It would be expected in Enterprise 10.9.1 since we fixed the bug after that release, but dev 1.7 should work fine. Is it possible to share the map data that you are using? Thanks.

0 Kudos
AndrewVentham
New Contributor III

Hi @TonghuiMing,

  I don't think we could very easily share our data, but here's a screenshot of the JavaScript error(s). I wonder if it's a subtly different bug, since the minified object name is "r" rather than "s"!?queryparams_error.png

 

0 Kudos
Ashok
by
New Contributor III

Hi,

 

Can someone help on this issue. This issue still open, without fixing this issue can not move further.

 

Thanks,

Ashok

0 Kudos
HaitingHuang
New Contributor III

For my case, it was caused by an Image Service that contains group layers (actually multi-level group layers). By removing the specific Image Service layer from the web map, the error in the ExB was gone. 

HaitingHuang_0-1643984555776.png

 

TonghuiMing
Esri Regular Contributor

Hi Ashok, we are still trying to locate the issue but have not yet successfully reproduced it. Are you still using Enterprise 10.6.1?

Notice that we fixed the previous issue (ExperienceBuilder Online Error: s.getCurrentQueryParams is not a function) in 9.3/AGOL 2021 Oct release/Dev 1.6, while 10.9.1 Enterprise is equivalent to Dev 1.5 code - see https://developers.arcgis.com/experience-builder/guide/about-versions/ for a reference - which means, only the next upcoming enterprise version will pick up on that fix.

I have tried several data reported by users earlier, which contains grouped tiled layers in the latest prod environment (same as dev 1.7), and it works fine too...

0 Kudos
TonghuiMing
Esri Regular Contributor

The problem with grouped raster/imagery layers should be fixed with today's AGOL 10.1 upgrade. Please check again. Thanks.

0 Kudos
Ashok
by
New Contributor III

Hi @TonghuiMing 

 

I am not getting this issue now a days. I am using ExB developer edition version 1.7 and ArcGIS Enterprise 10.6.1.  I hope the issue has fixed. 

 

Thanks,

Ashok

0 Kudos