Filter Widget In Widget Controller - Closing Filter Dialog Clears Filter

837
12
Jump to solution
08-19-2020 07:30 AM
DaveFullerton
Occasional Contributor III

I have a Filter Widget in a Widget Controller (and a List Widget).  First, I open the Filter Widget dialog and apply the filter (reducing the number of items in the list, as expected).  Then when I close the Filter Widget dialog, the filter is un-applied (all items are again visible in the list).  I noticed this in ExB DevEd v. 1.1.  I started up ExB DevEd 1.0 and this behavior does not exist there.  Was this an intentional change?

The behavior also exists in the online version.  Below is a link to an ExB app that demonstrates it: 

Experience 

0 Kudos
1 Solution

Accepted Solutions
ShengdiZhang
Esri Contributor

Hi Dave,

This bug should be fixed in the latest June update.

Regards,

Shengdi

View solution in original post

12 Replies
DavidMartinez
Esri Regular Contributor

Hi Dave,

This is a bug, thanks for pointing this out. I will log it and will take care of it. The issue is with the single selection in the controller as multiple works.  As a workaround, you could use multiple for now. Here is the same experience with multiple Experience 

Cheers,

David

DaveFullerton
Occasional Contributor III

Thanks, David.  I only have one widget in the controller, so the workaround has no unwanted side effects!

DaveFullerton
Occasional Contributor III

Unfortunately, the workaround does not solve the problem on small devices.

0 Kudos
DavidMartinez
Esri Regular Contributor

Hi Dave,

Thanks for letting us know. BTW, the single selection for how many widgets can be opened will be fixed in our next release.

David

DaveFullerton
Occasional Contributor III

I have also noticed something else, and I don't know if it is part of the same bug or if it is intentional by design.  My Filter Widget is in a Widget Controller.  I set the option "Apply this filter automatically" to one of the filters.  I load the experience and the filter is not applied until I open the Filter Widget.  I would rather it be applied when the experience is loaded.

Looking at the documentation, it says:

  • Apply this filter automatically—When users open the app, this filter is already applied to the data. Users can turn off the filter in the widget.

So I do think this is probably related to the same bug.  I am hoping it is fixed in version 1.2.

0 Kudos
TonghuiMing
Esri Contributor

Hi Dave,

This behavior is by design for the Widget Controller - until the panel for this specific widget is opened, the Widget Controller unfortunately does not control the widget internal setting similar to what you mentioned here. Will try to keep that in the doc if possible.

Thanks,

Tonghui

0 Kudos
DaveFullerton
Occasional Contributor III

The bug Filter Widget In Widget Controller - Closing Filter Dialog Clears Filter has been fixed for single and multiple selection on large and medium devices. In v1.3 it still is a problem on small devices for both single and multiple selection.  You can try it out here:

https://experience.arcgis.com/experience/c5956392d8114b9f8eaa30808238dd6d/

0 Kudos
BrittanyBurson
Occasional Contributor III

Thanks for the update @DaveFullerton. Our current project deliverables requires Mobile/small device support. Were you given an ETA for a fix on small devices? I opened a case today to track the bug, but any additional insight you may have is helpful. Thank you

0 Kudos
DaveFullerton
Occasional Contributor III

All I can tell you @BrittanyBurson is that I reported that bug, and that Technical Support informed me yesterday that the bug had been logged.  Product Manager @Jianxia is following up on it.