[Bug ?] jimu-arcgis dependency => TypeError this.mapView is undefined

1925
10
02-07-2022 05:34 AM
D_P
by
New Contributor II

Hi all,

adding the jimu-arcgis dependency in the manifest.json causes the following error in custom widgets. I've tried this with my own code and esri's js-api-widget in Exp.B. 1.6 & 1.7. Is anyone else getting the error?

Uncaught (in promise) TypeError: this.mapView is undefined
    updateMapView https://localhost:3001/widgets/arcgis/arcgis-map/dist/runtime/widget.js:1
    componentDidUpdate https://localhost:3001/widgets/arcgis/arcgis-map/dist/runtime/widget.js:1
    promise callback*componentDidUpdate https://localhost:3001/widgets/arcgis/arcgis-map/dist/runtime/widget.js:1
    React 14
    u https://localhost:3001/jimu-core/index.js:2
    createResizeHandler https://localhost:3001/jimu-core/index.js:2
    createResizeHandler https://localhost:3001/jimu-core/index.js:2
    t https://localhost:3001/jimu-core/index.js:2
    React 15
    startRenderMap https://localhost:3001/widgets/arcgis/arcgis-map/dist/runtime/widget.js:446
    setTimeout handler*execute/Ie/this.startRenderMap https://localhost:3001/widgets/arcgis/arcgis-map/dist/runtime/widget.js:446
    componentDidMount https://localhost:3001/widgets/arcgis/arcgis-map/dist/runtime/widget.js:603
    React 8
widget.js:1:26069

 

0 Kudos
10 Replies
D_P
by
New Contributor II

Yes sorry my last posting was off topic. However strangely the import of jsapi modules did work on localhost without the dependency in manifest.json and online in Firefox with empty cache. Maybe I can find my old code if it's of interest to you. I had reached out to esri germany about this error but they couldn't help me either.

0 Kudos