Select to view content in your preferred language

Disabling pop-ups won't work in ArcGIS Earth

418
1
Jump to solution
11-23-2022 08:04 AM
GeoffroyRicher-Lalonde
Occasional Contributor II

I have an ArcGIS Online Web Map with some layers that have the Enable pop-ups option disabled.

In ArcGIS Online Map Viewer and Map Viewer Classic, this option is respected : no pop-up is shown when clicking on the layer elements. But ArcGIS Earth do not respect that option, and I get pop-ups on those layers anyway.

Do you know of a workaround ? Can this be fixed in a later version ?

Thank you.

Geoffroy Richer-Lalonde
GIS Specialist, Hydro-Québec
1 Solution

Accepted Solutions
Sharon_MU
Esri Contributor

Hi @GeoffroyRicher-Lalonde ,

Great thanks for your feedback !

This requirement has been on our roadmap,  and now I'm glad to share with you that it will be introduced at the next release (V1.18)  in this year.

If 'some layers that have the Enable pop-ups option disabled.',  ArcGIS Earth will respect this option.

Please have a try when the next version is released, hopefully in Q1 this year.

Stay tuned.

 

Thanks.

Sharon Mu

 

View solution in original post

1 Reply
Sharon_MU
Esri Contributor

Hi @GeoffroyRicher-Lalonde ,

Great thanks for your feedback !

This requirement has been on our roadmap,  and now I'm glad to share with you that it will be introduced at the next release (V1.18)  in this year.

If 'some layers that have the Enable pop-ups option disabled.',  ArcGIS Earth will respect this option.

Please have a try when the next version is released, hopefully in Q1 this year.

Stay tuned.

 

Thanks.

Sharon Mu