EsriRegistrationMgr:02:22:30:Fatal error: Could not load ArcGISVersion (Windows Server 2012 R2)

3477
8
03-01-2018 02:07 PM
CelineKayitana
New Contributor

Hello,

I am trying to install ArcGIS Desktop 10.6 on a new VMware Virtual Machine, which has Windows Server 2012 R2.

Whenever i run the installer, i get the below error:

Once I click ok, the installation continue and gives a successful message. But when i open the app, it gives the below error:

Is there anyone who can assist on this issue?

Thank you and best regards,

Celine.

0 Kudos
8 Replies
JayantaPoddar
MVP Esteemed Contributor

Does it have any other ArcGIS product installed in it?

If a Repair doesn't work, I would suggest contacting the Esri support to resolve this issue.



Think Location
0 Kudos
CelineKayitana
New Contributor

Hi Jayanta,

No, it is a new VM set up just to host the ArcGIS Desktop and doesn't have any other product installed on it. 

I will try the repair and get back to you.

Best regards,

Celine.

0 Kudos
LaureneKoman
Occasional Contributor III

Please send me screenshots of two things:

1. The files listed in the x86 Common Files\ArcGIS\Bin folder.

2. The installed programs listed in your Add/Remove Programs.

I've posted the screenshots I've taken from my machine of the same.    You can post them here or email me directly at Lkoman@esri.com.

0 Kudos
CelineKayitana
New Contributor

Hi Laurene,

Sorry to delay, I couldn't access our customer server on weekend.

Here are the screenshots of taken from the machine on which the installer failed.

From the control panel

From the program files

We did a test and created another virtual machine and installed another version of windows  (windows 10 pro) and strangely, the installation perfectly worked. Hence, it may be related to Windows server 2012 R2

Best regards,

Celine.

0 Kudos
LaureneKoman
Occasional Contributor III

The files look good and the correct Cruntime was installed by the ArcGIS Desktop setup. We can’t repro this issue on clean Windows Server 2012 R2 machines so I don’t think it’s an issue with that OS, just something specific to this particular machine.

We’ll keep trying variations here to see if we can repro and provide more feedback.

Thanks

0 Kudos
CelineKayitana
New Contributor

Thank you Laurene for helping.

Actually we decided to create a new VM with Windows pro 10 and Windows Server 2012 Datacenter, and  the ArcGIS Desktop installation worked properly. We can't figure out why it cannot work with Windows Server 2012 R2 Datacenter.

I now have a different follow up question. But I think I can create another post for it.

Thank you,

Celine

0 Kudos
LevinConway
New Contributor III

Celine,

We ran into the identical problem on WS2012R2 Standard

THANK YOU for posting your screenshot as it clued us in to the solution.  The Visual C++ Redistributable (x86) 14.10.25017 installed by VMWare Tools appears to trigger the error with the ArcGIS Engine 10.6 installer when run on WS2012R2.  I downloaded a newer redistributable (14.13.26020) and installed it over the top of the existing one, then ran the 10.6 Engine installer and it installed without the error.  ESRI will likely need to modify their installation package but in the meantime the updated redistributable can be downloaded here:

https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads 

Thanks,

Levin

0 Kudos
ChrisStanley
New Contributor II

I just wanted to follow up with some additional information on this.  I got the same error as first reported when installing ArcGIS Engine 10.6.1 on a Windows Server 2012 R2 server.  I tried the above link to run the latest Visual C++ Redis and that didn't help me get rid of the error.  After troubleshooting with ESRI Support for a while we went to the below URL and I downloaded the one for my version of Windows and this fixed the issue.  After I installed this I was able to install ArcGIS Engine 10.6 without error.

https://support.microsoft.com/en-us/help/2999226/update-for-universal-c-runtime-in-windows 

0 Kudos