ArcMap says not licensed, but ArcGIS Administrator says licenses are avaliable

8972
5
Jump to solution
12-04-2017 03:09 PM
RichardDaniels
Regular Contributor

In ArcGIS Desktop 10.3.1 (and now ArcGIS Desktop 10.5.1 after upgrade) I have a computer were ArcMap will not start. When I attempt to start ArcMap (or ArcCatalog, ArcScene, etc.)  it says 'You are not licensed for ArcGIS for Desktop Basic. Use the ArcGIS Administrator to view the software available'. When I run ArcGIS Administrator it shows I've select Basic and that I have many BASIC licenses available. Pinging the license server returns the expected IPv4 results. I've check the IPv4 connection and it is active (vs. IPv6).

Ideas?

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
RichardDaniels
Regular Contributor

In this case adding the port number to the license server name 27004@myLicenseServer appeared to fix the issue. We had tried the FLEXLM_TIMOUT=5000000 (5 seconds) but that appeared to have no impact on this issue since the 'you are not licensed' window would pop up immediately after starting ArcMap (no 5 second delay was seen).

I also found that the registry setting for in [HKCM\SOFTWARE\WOW6432Node\ESRI\License10.5] for the "DESKTOP_CONFIG"  key was set to "FALSE". I changed this to TRUE to match my other working installations. How this became FALSE is unknown.

Note - the office location with the problem was using a VPN as well.

Thanks for the ideas :-).

Rich

View solution in original post

5 Replies
Greg_Mattis
Occasional Contributor II

When you upgraded your license, did you also upgrade your license manager to License Manager 10.5.1?

Greg Mattis, GISP
GIS Analyst
City of Visalia
0 Kudos
RichardDaniels
Regular Contributor

yes the ArcGIS license manager is at 10.5.1.

Note - it is not a user environment issue since multiple people have had the same issue on this machine.

Rich

0 Kudos
JayantaPoddar
MVP Esteemed Contributor

Did you the expiry date also? Could you share a screenshot of the availability list in ArcGIS Administrator?



Think Location
0 Kudos
RichardDaniels
Regular Contributor

As requested. 

I also installed ArcGIS Pro on this machine. I have Pro setup to use Concurrent Use licensing and the licenses area installed on the same server as ArcGIS Desktop licenses. Interestingly ArcGIS Pro can reach the server and get a license (Basic) while ArcMap, on the same machine, cannot. 

Rich

0 Kudos
RichardDaniels
Regular Contributor

In this case adding the port number to the license server name 27004@myLicenseServer appeared to fix the issue. We had tried the FLEXLM_TIMOUT=5000000 (5 seconds) but that appeared to have no impact on this issue since the 'you are not licensed' window would pop up immediately after starting ArcMap (no 5 second delay was seen).

I also found that the registry setting for in [HKCM\SOFTWARE\WOW6432Node\ESRI\License10.5] for the "DESKTOP_CONFIG"  key was set to "FALSE". I changed this to TRUE to match my other working installations. How this became FALSE is unknown.

Note - the office location with the problem was using a VPN as well.

Thanks for the ideas :-).

Rich