Refresh of Charts showing WorkForce Assignments

128
3
10-03-2019 08:44 AM
Highlighted
New Contributor III

How do I go about getting dashboard objects that show WorkForce Assignments (or Workers) to automatically refresh?  The map element on my dashboard is showing the "Dispatcher Map", and both the 'Assignments' and 'Workers' layers have the Refresh interval set to 1 minute, yet nothing in my dashboard will refresh unless I do a manual refresh of the entire webpage.

Thanks,

Reply
0 Kudos
3 Replies
Highlighted
New Contributor III

And to add to this...

After making an update to an assignment, in the Dashboard List item I see no changes, but if I go into the 'Settings' for the List item, in the preview of my data, I see the updates....it just doesn't get refreshed in the Dashboard.

Here it is in the Dashboard.  The indicated item should be showing as green.

In the settings...as it really is, and should be showing in the Dashboard.

The Map item does seem to get refreshed.  I can see the assignment has turned to green there, but not in the List or the Chart at the bottom.

Reply
0 Kudos
Highlighted
Occasional Contributor II

Hi Brian. Did you define your refresh interval at the layer item level or on the layers within the dispatcher map? 

If defined at the layer item level, you may be running into a bug (where the definition doesn't isn't properly read). 

Try defining the refresh interval on the layers within the webmap. The refresh interval should then be honored in the dashboard map layers and visual elements using these layers.

Highlighted
New Contributor III

The refresh is set within the layers in the webmap.

It does seem to be working today.  Previously I had always been watching the dashboard within the 'builder' application.  Today I am looking at my builder through the 'end user' view of the dashboard.  Do you think that is the difference?  Do the various objects insert into the dashboard not refresh properly when using the 'builder'??

Reply
0 Kudos