Operations dashboard List widget Portal for ArcGIS 10.6 not responding

652
6
11-16-2018 02:37 AM
wadsonmakari
New Contributor III

Hi all,

I am working on Operations Dashboard in Portal for ArcGIS 10.6 but I am having trouble configuring the List element on my dashboard.

The element provides 3 config options on the top left Data (to preview that populating my list, I can preview data from the layer that I need to populate the list), List (to configure the contents and appearance of my list). It is the List option is not configurable for me for some reason. None of the controls on the List options are working for me I can't even change the colour of text etc. Furthermore the dropdown ({ }) to choose columns  to display is not doing anything when I click on it.

I know that my data is there as I can preview it under the data option it is only when I try to configure the List appearance that configure UI does not respond at all. I don't any errors at all but nothing happens.

I have reinstalled Operations dashboard but I still can't configure my List. Have I missed something basic?

Regards,

0 Kudos
6 Replies
DerekLaw
Esri Community Moderator

Hi Wadson,

Suggestion from a colleague on the Ops Dashboard team,

"... did you bump up the value of the Maximum Displayed Features to a high number? "

Hope this helps,

0 Kudos
wadsonmakari
New Contributor III

Hi Derek,

Thanks for responding. No I haven't the feature service only has 69 points. I have tried setting the Maximum Displayed Features to just 10 but I am still getting the same behaviour.

0 Kudos
wadsonmakari
New Contributor III

Further to my earlier comment I can configure a selector on the header panel and there I can access my feature service attribute data and I see all the columns.

It looks like this problem is happening with the List element.

0 Kudos
DerekLaw
Esri Community Moderator

Hi Wadson,

Does the data work in the other Ops Dashboard elements, like the Serial Chart?

What kind of data/web service is it?

Thanks,

0 Kudos
wadsonmakari
New Contributor III

Hi Derek,

Yes the data which as coming from a feature service partly works with a serial chart i.e. I can select the data to chart and produce a chart etc. However, on the general tab I can specify the title of my chart for instance but I can't change the color of the title or centre it etc.

Do you think there could be something wrong with my environment i.e. browser version/setttings etc

0 Kudos
DerekLaw
Esri Community Moderator

Hi Wadson,

The behavior you've described suggests that something is amiss with your Operations Dashboard installation.

> Do you think there could be something wrong with my environment i.e. browser version/setttings etc

Perhaps, please check the install requirements, What are the requirements?—Operations Dashboard for ArcGIS | ArcGIS 

Otherwise, I suggest you contact Esri Tech Support so they can help investigate your issue in more detail.

Hope this helps,

0 Kudos