Operations Dashboard in a browser

3712
7
04-04-2014 03:40 PM
TifPun
by
Occasional Contributor II
Since the release of the browser version of Operations Dashboard we have received a lot of questions from our users. The team has published a blog article, describing how to author operation views that can be used in the browser, and highlighting the capabilities within the browser app.

http://blogs.esri.com/esri/arcgis/2014/04/03/operations-dashboard-in-a-browser/
7 Replies
EdHarrell1
New Contributor III

I just installed the latest update for the Ops Dashboard.  I am now no longer able to see it in a browser.  If this is an unkown issue, I wanted to make it known.  Thanks and cheers!

0 Kudos
CarolGhostine
Esri Contributor

Hi Ed,

Could you provide more details about your issue. What is the message you are seeing when you say " I am now no longer able to see it in a browser" ? How are you opening your dashboard in the browser? From a shared link or from the items details link from AGOL? If you have mixed content in your op view sometimes the browser will block it from launching the app. If the link in the browser says https:// .... try removing the (s). More detail about your issue would be great to narrow down the problem.

Thanks

Carol

EdHarrell1
New Contributor III

Hi Carol,

Thanks for your fast reply and please accept my apologies for my slow one.  It doesn't matter what device, browser, or method that I use to load the dashboard (hyperlink or the "Open in" option in AGOL), it simply fails to load.  I have no https and all 4 feature services are hosted in my AGOL organzation's account.  I have messed around with one of the editable feature services several times, I'm thinking about going back and creating it from scratch to see if that helps.  Thanks again for your reply.  Cheers!

Dashboard.PNG

0 Kudos
CarolGhostine
Esri Contributor

Not a problem Ed. I would suggest you try to isolate the issue by adding one layer at a time in your op view and see if it loads. You may have already done so?

-Carol

0 Kudos
SannyaDang
New Contributor

Hi Carol,

I'm having the exact problem as Ed, as I tried IE, Chrome and Firefox on Windows and iPad with iOS 7 running Safari. When I turn on the developer tools to track the network, I found out that the following libraries link don't load:

http://{name}.maps.arcgis.com/apps/dashboard/js/dojo/dojo/dojo.js.map

http://{name}.maps.arcgis.com/apps/dashboard/libs/jquery/jquery-1.10.2.min.map

http://{name}.maps.arcgis.com/apps/dashboard/js/dojo/dojo/nls/dojo_ROOT.js.map

with {name} being our organization's name. Here's the screenshot for your reference.dashboard errors.jpg

0 Kudos
EdHarrell1
New Contributor III

I haven't done that and haven't thought about doing that.  Thanks!

0 Kudos
EdHarrell1
New Contributor III

I Just tried again after the newest update. It now works beautifully in a browser.