operations dashboard error when viewing as anonymous

3250
16
Jump to solution
09-24-2015 04:42 AM
SvivaManager
Occasional Contributor II

Hello,

I created a simple project on the operations dashboard that shows a webmap - no widgets or nothing else but a webmap with nothing special in it.

I saved the project and shared it with everyone.

When I try to access the application as a named user it shows up well.

When I try to access the application as anonymous, I get an error - I have attached a screenshot.

Did anyone else experienced this before? should be very simple and easy to reproduce..

The console window throws an error referring to the js framework which fails to load the map but I couldn't find any connection with identifying the connected user (which is the reason for this error apparently)

Same behavior with Chrome and IE

0 Kudos
1 Solution

Accepted Solutions
ChristopherOlsen
Regular Contributor

This is something that should be fixed in the 10.4 version of Portal. It was just released a couple weeks ago so once you can upgrade to that, this issue will be resolved.

View solution in original post

16 Replies
SvivaManager
Occasional Contributor II

This behavior appears to happen with basemaps different then those which ESRI provides and using a different spatial reference number then 102100. If anyone is able to reproduce this issue I'll appreciate the help to verify that this is a bug

0 Kudos
TifPun
by
Occasional Contributor II

Hi Sviva,

We came across a similar bug but that one was fixed a while back. Could you check if your basemap has been shared publicly, and if so, will you be able to share with me your operation view so I can take a look? My ArcGIS Online username is tif.geonet in case you need it.

Cheers,

Tif

0 Kudos
SvivaManager
Occasional Contributor II

Hi Tif,

Thanks for writing. The basemap is shared publicly but it's all inside our organization on local servers and cannot be accessible from the outside.

From what I know, ESRI already acknowledged this issue as a bug.

Thanks anyway,

Shay.

0 Kudos
ChristopherOlsen
Regular Contributor

Hi Shay,

What projection is your basemap in?  Are you trying to access the web dashboard or desktop one when you share it out?

Here is a quick test I made with a custom basemap layer and public access:

Operations Dashboard

Thanks,

Chris

0 Kudos
SvivaManager
Occasional Contributor II

Hi Chris,

Our basemap's spatial reference is 2039. On the desktop side it works perfectly fine. on the web it doesn't as an annonymous

0 Kudos
SvivaManager
Occasional Contributor II

your sample seems to throw me an error as well but it's a clear message saying your basemap is not accessible. Thank anyway

0 Kudos
ChristopherOlsen
Regular Contributor

Does the webmap work with anonymous access?

Do you have anonymous access checked in your org settings under Security? (you will need to be logged in as admin)

0 Kudos
SvivaManager
Occasional Contributor II

Yes I have anonymous access enabled. Your settings window looks completely different from ours

111.JPG

0 Kudos
ChristopherOlsen
Regular Contributor

Does the webmap work with anonymous access? Can you send me the link?

0 Kudos