HTML from webmap Pop-Up not working in details pane in new release of Dashboards

424
4
04-15-2021 08:31 AM
WestervilleGIS
Occasional Contributor

In the newest release of Dashboards, HTML tags that are used in the webmap pop-up are not working properly in the details pane of the Dashboard.  If I switch to Dashboards classic, the HTML tags are recognized.  Is anyone else having issues with this?  I would like to update my dashboards to the newest versions but need the HTML from the webmap pop-ups to work properly.  Please see attached pictures.

Tags (3)
4 Replies
SandraLuken1
Esri Contributor

Are you seeing the same thing in the new map viewer (not classic) ? Or is this only reproducible in dashboards? 

0 Kudos
WestervilleGIS
Occasional Contributor

The pop-ups in both the classic map viewer and the new map viewer show the HTML code.  But in the configuration for the Details pane of the classics dashboard, I have the Contents button turned on to show the pop-up from the web map and the HTML works to structure/format the text properly.  For the same situation in the new dashboards, the HTML code is shown instead.

0 Kudos
WestervilleGIS
Occasional Contributor

Has anyone else seen this issue?  Basically, what I am doing is using Arcade to generate some really basic HTML to create bulleted lists based on if attributes are present in particular fields.  I then have the Arcade Expression in the Pop-Up content for that layer.  In both Classic Map Viewer and the New Map Viewer, when you click the the feature, the Pop-Up will not render the HTML code properly.  In fact, it just shows the code rather than the bulleted lists.  However, if you use the map in a Classic Dashboard, the HTML displays properly.

0 Kudos
BrittanyBurson
Occasional Contributor III

Hi @WestervilleGIS and @SandraLuken1, I am experiencing this as well. I have a few combo Arcade/HTML expressions that populate the pop-up text as Teal or Orange corresponding to status, and then showing the details if they exist.

Classic Dashboards (/apps/dashboards/):

BrittanyBurson_0-1626882415160.png

"New" Dashboards (/apps/opsdashboard/):

BrittanyBurson_1-1626882445322.png

I see the same behavior in the new Map Viewer:

BrittanyBurson_2-1626882562864.png

Map Viewer Classic:

BrittanyBurson_3-1626882617427.png

Classic Dashboards works as expected (since TextFormatting.NewLine not supported in JS 3.x apps)
New Dashboard and New Map Viewer, it ignores the calculations and returns the default "Else" instead of the calculation. Some of the calculations use FeatureSetBy functions, but others are fairly simple, like the primary example above:

if ( DomainName($feature,"Maint_Status") == 'Scheduled') {
return "Scheduled"
}
else if ( DomainName($feature,"Maint_Status") == 'Completed') {
return "Completed"
}
else  {
return "Not scheduled for maintenance at this time"
}

 

Interestingly, if I use the "Select" tool first to click a feature in the New Dashboard, and then click out of the Select tool, the pop-ups then begin working as expected. But I can't ask my users to remember to do this.

BrittanyBurson_5-1626883117252.png

We've had other apps, such as Experience Builder, that had their HTML driven pop-ups "break" a few weeks ago in the JS 4 maps and apps. I wonder if it is related?

Thanks for posting.