DB will not display PDF links when embedded in a storymap or experience

993
9
Jump to solution
04-14-2021 10:36 AM
RachelK
New Contributor II

Hello,

I'm building a dashboard with an embedded PDF. When I open the dashboard, everything works as it should, but when I add the dashboard to a storymap or an experience, I get an error message where the PDF should be. It reads, "Requests to the server have been blocked by an extension." Any help with this would be appreciated.

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
SandraLuken1
Esri Contributor

Looks like you are running into this issue https://support.esri.com/en/bugs/nimbus/QlVHLTAwMDEzMjU1NQ==. There is a suggestion listed to try a Chrome extension such as the PDF viewer. 

View solution in original post

9 Replies
SandraLuken1
Esri Contributor

Hi Rachel

Can you confirm the browser that you are using? Is this just happening with Chrome and Edge?

0 Kudos
RachelK
New Contributor II

I'm using Chrome. This is a work project and we can only use Chrome, Edge, or Explorer. Everything works as it should when I open the dashboard on its own. The error pops up when I add the dashboard to a storymap or an experience.

0 Kudos
SandraLuken1
Esri Contributor

Looks like you are running into this issue https://support.esri.com/en/bugs/nimbus/QlVHLTAwMDEzMjU1NQ==. There is a suggestion listed to try a Chrome extension such as the PDF viewer. 

View solution in original post

RachelK
New Contributor II

Thank you!

0 Kudos
AndrewHeimark
New Contributor II

We are having a similar issue with our Municipal Ops Dashboard (Municipal Dashboard (arcgis.com)). Every PDF link we have embedded in the dashboard has that same error in Chrome and Edge "Requests to the server have been blocked by an extension."  Unfortunately, this is a publicly available dashboard so people will not know to use Firefox or to download an extension on their browser, they will just think the links are dead.  We have over 100 PDF links tied to this one dashboard and I'm hopeful that this bug will continue to be worked on until there is a resolution.

0 Kudos
RachelK
New Contributor II

Our inelegant workaround was to convert the PDFs we needed to JPG. It's not a great solution, but because our client wanted these specific pages with this specific information, we went with it. Here's hoping for good news soon(ish) on this issue!

0 Kudos
AndrewHeimark
New Contributor II

Thanks for the tip! Unfortunately about 90% of the PDF links we have in this dashboard are from an outside source. I'm hoping for a resolution soon too because we may have to overhaul our entire dashboard for this one bug.

0 Kudos
GISManager4
New Contributor III

I am having same issue, but when I attempt to embed a jpg the screen in blank. What was your solution?

GISManager4_0-1620847966838.png

 

0 Kudos
RachelK
New Contributor II

These are the steps we took:

  • we host the jpgs on our server so they have a url
  • we created a field called "link" in the data layer and added the jpg urls to that field
  • when configuring the embedded element, we pointed it at that link field

RachelK_0-1620909576213.png

Hope this makes sense/helps!

0 Kudos