Database view feature layer won't visualize in dashboard

575
3
03-08-2021 09:12 AM
Labels (3)
GeoMarvel
New Contributor

We've created a SQL view from SQL MGMT Studio, and published to an Enterprise geodatabase. This visualizes fine, and we can successfully publish to Portal/AGOL without a problem. Within Portal/AGOL, we can see the data table and visualize both the map image layer and feature layer versions of the view.

We encounter an issue when attempting to visualize the Feature layer version of the view within a Dashboard. The feature layer view will not display points within the dashboard (even though it works in a web map). But the map image layer displays those same points just fine. We also created an indicator that accurately picked up the total number of points within the map extent, even though there were no points visible.

Any input on why the feature layer version of the view will not display in a dashboard?

0 Kudos
3 Replies
JohnSolly4
Esri Contributor

Hello,

I am going to guess you are using ArcGIS Dashboards from within ArcGIS Enterprise. Is that correct? If so, what version of enterprise?

 

I suggest reaching out to Esri support if this is an enterprise issue.

0 Kudos
DaltonBloom
New Contributor II

Hi John, thanks for the reply. This issue was occurring when using ArcGIS Dashboards with ArcGIS Enterprise 10.8.1. We have since solved this issue. We were using a SQL CAST function to display lat/long values as points, which seemed to have an impact on the point visibility within a dashboard view. But after altering the SQL statement to use STGeomFromText instead of CAST, we were able to visualize the points within the dashboard. 

JohnSolly4
Esri Contributor

Thanks for the update. I will look into what you just mentioned to see if I find an answer to why you couldn't do that.

0 Kudos