Dashboard data won't load using query 'Is within the last 365 days'

1059
10
Jump to solution
04-14-2021 08:31 AM
Curt_H
by
New Contributor III

Today, after Dashboard Beta moved out of Beta, Dashboard components cannot access a data source (a hosted feature layer view) when the query is: 'Date is within the last 365 days'.  Querying 'Is before the Last 365 days' loads fine. See screen cap:

CurtHarveyNIFCContractor_0-1618414026746.png

Prior to today, the query worked fine. The issue occurs in both Dashboards (previously Beta) and Dashboards Classic.

Thanks!

1 Solution

Accepted Solutions
Curt_H
by
New Contributor III

Maybe this will be addressed? A new banner - I think this just showed up today? Its a banner on any web map opened....

Curt_H_0-1618434257463.png

 

View solution in original post

10 Replies
Jelle_Stuurman
Occasional Contributor

Have you tried recreating the component? When the dashboard beta moved from beta version 1 to beta version 2, this worked for me.

0 Kudos
Andrew_Purdon
New Contributor III

Hi @Curt_H and @Jelle_Stuurman 

I am having the same problem with several dashboards with unrelated data. I have tried making new ones using Dashboards and Dashboards Classic using both the new and classic map viewer and I get the same errors. The data are displaying on the maps, but the widgets aren't working like they used to a few hours ago.

AndrewPurdon1_0-1618416124564.png

 

Co-founder of M.A.P Scientific Services
0 Kudos
Curt_H
by
New Contributor III

Hey Andrew - Good to know (but sorry your having the same issue) that I'm not alone.

Hopefully resolution is coming.

Curt_H
by
New Contributor III

Hey Jelle - as soon as I select Query is within by days, on a component the data table unloads. It definitely doesn't like that query parameter.

 

Thanks

0 Kudos
VivekMalleshappa
Esri Contributor

Hi, 

I can help investigate. 

@Curt_H , @Andrew_Purdon - could you please share the Dashboard or the feature layers used in these elements? Feel free to direct message me if you cannot share the data publicly. 

-Vivek.

 

JingCao12
New Contributor II

Hi everyone,

I am having similar issues in dashboard after the upgrade from yesterday, components shows can not access data. I've tried recreating components, issue is still presenting. 

Hopefully ESRI will investigate and provide a solution soon. 

0 Kudos
Andrew_Purdon
New Contributor III

Hi @JingCao12 

The problem seems to be a new rate limit that has been implemented with the update. Following these best practices may help https://doc.arcgis.com/en/dashboards/reference/build-highly-scalable-dashboards.htm

Unfortunately, I still think it is going to be a problem for a lot of us. 

Co-founder of M.A.P Scientific Services
JingCao12
New Contributor II

Thank you @Andrew_Purdon This is a bummer, I see they don't recommend using relative date filters in the new dashboard anymore. I wonder what are the alternatives out there. 

Curt_H
by
New Contributor III

Maybe this will be addressed? A new banner - I think this just showed up today? Its a banner on any web map opened....

Curt_H_0-1618434257463.png