Can't Sort By Statistic Due To Cannot Access Data Error - Serial Chart

1175
8
07-29-2019 02:41 PM
JustinPence2
Occasional Contributor

I am trying to create a serial chart, that shows the top rig operators.  The layer is a hosted feature service, and contains individual points.  My category field is Operator Name, and my statistic is count.  The table will then display the number of rigs per operator name.  However, when I try to sort by statistic, I get the error, "Cannot Access Data."  

Again, this is a hosted feature service, and by looking at the metadata, statistics are enabled for this layer.

Ultimately, I would like a chart showing the top ten operators by Rig Count in a geographic area that updates as you zoom in/out in the map.  

Update: I've tested this on ArcGIS Online, and have no issues running the same exact scenario.  However, when I try in Portal 10.7, I can't sort by statistic.  I assume I've encountered some type of bug

Any ideas?

8 Replies
LindsayMaier
New Contributor III

I have the exact same problem. No idea what is going on. It was never a problem in ArcOnline, but in our Enterprise portal, it says "no data" -- it's driving me nuts!

0 Kudos
JustinPence2
Occasional Contributor

After reporting the issue, they came back and were able to replicate the bug.  According to the #BUG-000120535, it will be fixed in Enterprise 10.8.  

LindsayMaier
New Contributor III

Thanks so much for the heads up! Hopefully 10.8 comes sooner rather than later...

0 Kudos
JustinPence2
Occasional Contributor

I know 10.8 is in the Pre-Release stage, so I assume it will be soon.

0 Kudos
NathanielSimmons
New Contributor III

I'm actually having this same problem as well, but it is on ArcGIS Online and not Enterprise... What I'm trying to do is even simpler than what you are describing. I just want to show the current number of features in a dashboard indicator, but I get the "cannot access data" message.

When configuring the indicator, if I click on "Show data table," all of the correct records show up. But when in "show preview" mode, it says "No Data" with that error message. 

Over the years that I've used GIS, it always seems like it's the simplest/most basic tasks that won't work correctly...

0 Kudos
MackenzieCarter
New Contributor II

Still not working  

0 Kudos
NajyaBatool1
New Contributor II

Hi everyone.  It does work in 10.8 - however in order for Portal to have access to the dataset to sort, it needs to be copied to server.  In Pro, please choose to copy all data when publishing and it'll work! 

MorganTitus1
New Contributor II

Hi Najya,

When you say "Server" do you mean the Portal hosting server or can this be a non hosting ArcGIS Server?  The latter is my case and in 10.8 the sorting by statistics still won't work.  Thanks for any clarification you can provide!

0 Kudos