Unable to enable offline mode

2429
7
Jump to solution
07-12-2017 04:27 PM
JosephAlberts
New Contributor III

I'm unable to set the Offline Mode for newly created web maps using only AGOL hosted feature layers. I'm not certain if this changed with the June 2017 updates; these are the first new web maps I've created since that time.

I've tried this even in an extremely simple, pared down instance using a hosted feature layer that is working fine along with others in previously created maps (created as recently as June). Here's the broad strokes:

  • The hosted feature layer is on AGOL
  • It is sync enabled
  • It's the only layer in the newly created web map
  • It is also edit enabled (Only update feature attributes)
  • The web map is completely new. I've tried both creating a new map then adding the layer to it, and selecting the layer from Content and Adding layer to a new map with full editing control
  • The hosted feature layer was published prior to the June Update, but is working normally in the maps where it existed before.

I'm attaching the full settings page for the hosted feature layer I'm testing against and the settings for the map. I've replicated the loss of this option with two other users in my organization, using the same and different hosted feature layers. Most, but not all, of these hosted feature layers were published prior to the June Update. Some were published today.

The option simply isn't shown on the web map settings.

I should certainly meet the minimum requirements for Offline Mode given in the docs (Prepare maps for offline use—Collector for ArcGIS | ArcGIS ). I noticed that those now say the map will be automatically enabled for offline use if the maps meets the requirements. I don't recall that being the case before; was this a change that occurred during the last update?

Is this something anyone else has seen? Any thoughts on it?

1 Solution

Accepted Solutions
JosephAlberts
New Contributor III

Having been unable to replicate this again since my last reply on July 13, and not knowing if anything changed in that small window of time on either AGOL or within my institution that fixed it, I have to assume that this was some sort of peculiar short term glitch.

*shrug*

View solution in original post

0 Kudos
7 Replies
JosephAlberts
New Contributor III

Got a bit of an update on this. It appears to be related to the base map, or the act of changing it. I'm using the standard base maps offered directly in web viewer.

I re-ran my test as follows:

  • Created a new map and saved it (while it was still empty); default base map is Topographic
  • Checked map settings. Offline mode is enabled.
  • Added the exact same, unchanged, feature layer from yesterday to the web map and saved it.
  • Refreshed and checked map settings. Offline mode is enabled.
  • Changed the base map to Streets in web map and saved it.
  • Refreshed and checked map settings. Offline mode option is removed (and disabled).
  • Changed the base map back to Topographic in web map and saved it.
  • Offline mode remains unavailable.

I've tried several other default base maps, and the option never becomes available/re-enabled.

0 Kudos
JosephAlberts
New Contributor III

About 5 hours later, I am now unable to replicate this result following the same methods. 

It also looks like I'm now able to correct the previously created maps that did not have offline mode available by switching their base maps to another and then back.

Something clearly changed...but I don't have the faintest idea what.

0 Kudos
KarenFolger
Occasional Contributor II

I'm having a similar problem which is baffling me too. I can get the Enable Offline checkbox to show up using the trick above, however it's not actually available in Collector. I have a work around but it's not a good one. 

  1. Publish a feature service with all the editing functions turned on including sync.
  2. Make a map from the feature service in AGOL - not sure making the map directly from the feature service is required but it's how I did it and got it to work. Perhaps it would work if you made a new map and added the feature service after, but it doesn't work with old maps. 
  3. Re-publish the feature service with all editing functions off including sync. I just want Collector to be able to view the data (Query only). 
  4. The map still works in Collector

If I make the map first without coming from the data, and if the data doesn't have editing on, then the map will never be available in Collector even when you re-publish the data with all editing on. This is baffling.

0 Kudos
JosephAlberts
New Contributor III

Hm. That sounds like it might be a little different. I always publish services with full permissions and then either restrict them at the feature layer level or at the map level.

You're ending up with an editable layer in the map in both situations? From my experience, if you don't have at least one editable layer, it won't show up for download in Collector.

Also, instead of publishing a different copy, you could make a View of your existing Feature Layer (Create hosted feature layer views—ArcGIS Online Help | ArcGIS). You could use that to further restrict access on the data, while still pointing to the same actual data source (the original Feature Layer).

0 Kudos
JosephAlberts
New Contributor III

Having been unable to replicate this again since my last reply on July 13, and not knowing if anything changed in that small window of time on either AGOL or within my institution that fixed it, I have to assume that this was some sort of peculiar short term glitch.

*shrug*

0 Kudos
JeremyL
New Contributor II

I have had similar issues with webmaps not having the "Enable Offline Mode" setting available. I am using Hosted Feature Layers, and in one case it appears to be related to a change in the basemap in ArcGIS Online. I changed the basemap from air photo to topo after creating and saving the webmap. "Enable Offline" option was not available (not even grayed out). All layers had sync enabled. When I changed the basemap back to the original default (air photo) the "Enable Offline" slider magically appeared. I have also used the approach as mentioned above of creating a new map and adding the layers again - that worked too.

JacobHelfman1
New Contributor III

Jeremy's answer should be the one marked as correct. I was able to replicate this and confirm that changing the basemap resolved the issue. It didn't make sense though becuase I changing from another AGOL basemap. 

0 Kudos