Unable to collect a new feature on Android phone in Collector

452
7
12-17-2018 03:49 PM
NicoleDenecour
New Contributor II

Some collector maps will not allow for the collection of new features ('+' missing completely) and no data is shown on the map when using my Android work phone, but the same maps work properly on my iPhone. Other users on my team have Androids and all their maps are working perfectly. The maps that I am having issues with are shared as a feature service through our ArcGIS Server. I contacted IT within our organization  and they thought it could be a bug within the Android software, but I wanted to see if it could possibly be an issue with the SDE/feature service. These maps have been working properly for months and suddenly stopped working. Hoping someone might have some insight or had a similar problem. 
Thanks! 

0 Kudos
7 Replies
PeteCrosier
Occasional Contributor III

Have you tried navigating to the feature service through Chrome - e.g. https://www.yourdomain.com/arcgis/rest/services/... - to see if you can get to it that way?

0 Kudos
NicoleDenecour
New Contributor II

The feature service is there when I navigate to the REST Server. It is shown as a Mapserver, FeatureServer, and MobileServer, as shown below.


All maps work perfectly on ArcGIS Online, iPhone Collector, and even some Android Collector. It seems to not be working on newer Android phones. 
I have tried uninstalling and re installing the collector app, but no luck thus far. 


0 Kudos
PeteCrosier
Occasional Contributor III

Is that screenshot from Chrome on the Android device itself? Does Chrome on the device report any issues with the security certificate for the domain in the address bar?

0 Kudos
NicoleDenecour
New Contributor II

I was able to pull up the REST server page on the Android itself. I don't see any issues with the security certificate in the address bar either. I think it might be an issue with the new Galaxy Note 8. These are the only phones that are not working in conjunction with Collector. I'll just see if I can get transferred to an older Android or iPhone for the time being. Thanks for you time, Pete! 

0 Kudos
NicoleDenecour
New Contributor II

I just downloaded the Collector Beta version and everything works perfectly! 

0 Kudos
DavidForbuss1
Occasional Contributor III

So the beta version is still available?  I already downloaded the release version and I'm having a similar issue.  I can collect features in "Classic" but not in the new version.  I wonder if getting the beta version might fix my issue as well.

0 Kudos
NicoleDenecour
New Contributor II

Yes, it seems to fix the issue. You might want to give it a try! It should still be available. I downloaded it from the Google Play Store yesterday. I am having issues with the Beta version crashing repeatedly though. 

0 Kudos