Time field in Collector

3152
1
Jump to solution
09-07-2016 04:32 PM
TimHayes1
Occasional Contributor III

The Collector Date input brings a time attribute with it, though it is not shown on the Collector Interface.

I would like to do one of two things:

1.       Create a new time attribute field that extracts the time from the date field and shows that separately

2.       Have both date and time shown on the collector screen and the mapviewer window.

is it possible to do one or both of these things?

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
peterNOTMEknoop
Occasional Contributor

You should be able to achieve #2 by changing the field's format in the pop-up. By default, date fields are displayed in pop-ups (hence, in Collector as well) using a date-only format (from Configure pop-ups:(

For date fields that include time, select a format that includes both. By default, only dates are displayed.

So choose an appropriate format that supports both date and time for your field, tick the box for "Show time", and then you will see both date and time displayed in your Web Map's pop-ups and in Collector.

Note that not all date formats will support displaying both date and time. Only short-date formats will display both; the "Show time" checkbox is grayed out when a other date formats are selected. This tidbit is unfortunately buried on the Troubleshooting page:

Time does not appear in the date field.

Only short date formats display time (for example, 12/31/1999 and 31/12/1999). Time is not displayed as part of the date field for other date formats. To display time for date fields, you need to configure the date field in the pop-up to use one of the short date formats (and check the box to show time).

I would also recommend taking a look at the "Considerations for date fields" section on Work with fields, which also has some useful information about date-time fields and formats.

-peter

_____________
Peter A. Knoop
University of Michigan | LSA Information Technology | Advocacy & Research Support

View solution in original post

1 Reply
peterNOTMEknoop
Occasional Contributor

You should be able to achieve #2 by changing the field's format in the pop-up. By default, date fields are displayed in pop-ups (hence, in Collector as well) using a date-only format (from Configure pop-ups:(

For date fields that include time, select a format that includes both. By default, only dates are displayed.

So choose an appropriate format that supports both date and time for your field, tick the box for "Show time", and then you will see both date and time displayed in your Web Map's pop-ups and in Collector.

Note that not all date formats will support displaying both date and time. Only short-date formats will display both; the "Show time" checkbox is grayed out when a other date formats are selected. This tidbit is unfortunately buried on the Troubleshooting page:

Time does not appear in the date field.

Only short date formats display time (for example, 12/31/1999 and 31/12/1999). Time is not displayed as part of the date field for other date formats. To display time for date fields, you need to configure the date field in the pop-up to use one of the short date formats (and check the box to show time).

I would also recommend taking a look at the "Considerations for date fields" section on Work with fields, which also has some useful information about date-time fields and formats.

-peter

_____________
Peter A. Knoop
University of Michigan | LSA Information Technology | Advocacy & Research Support