Sync Errors with offline maps

4452
21
Jump to solution
01-14-2016 12:19 PM
TravisAnderson
Occasional Contributor

I'm using an iPad Air running iOS 9.2, and Collector 10.3.6 with a external Arrow 100 GNSS receiver. I have downloaded maps and worked offline in the previous months (October-November) and haven't had any issues. Worked wonderfully! Since then there's been an update to iOS and a new release of Collector, both of which I installed. Now, if I download a map to use offline, and collect a new point (valve or hydrant) and then try to sync that point I get the following error:

An error occurred while trying to synchronizing edits. Unable to synchronize replica. Sync replica error

I don't actually have to gather a point. I still get the same error if I hit the sync button with nothing to sync.

My layers are pretty basic. They are just hosted feature layers on AGOL. They have not been modified from when they were initially uploaded in August. Besides updating the OS and Collector, the only thing that I have tried different was setting up a iPad mini. I downloaded an offline map to use in the field, and when testing it in the office this week I got the error for the first time. I had not tried syncing the existing iPad Air offline after the new updates were installed (iOS and Collector), so I don't know if I would have received the error before I set up the mini or not. I do receive the error on both now. Neither are logged in at the same time. I have noticed that even though I get the error, the collected feature does make it to AGOL. I'm not sure if it's every time or not. I'll have to check. I currently have no issues collecting data if I'm connected to internet service in the field.

Anyone else having the same issue or any thoughts as to what might be causing this?

0 Kudos
1 Solution

Accepted Solutions
DhrumilShah
New Contributor II

Delete all the text in update service definition text box. You only need this.

{"capabilities" : "Create,Delete,Query,Update,Editing"}

Once you hit update definition, sync capability should go away.

And then delete all text in update service definition, and enable sync with this:

{"capabilities" : "Create,Delete,Query,Update,Editing,Sync"}

If this does not work, need to delete the republish the service.

Thanks,

Dhrumil

View solution in original post

0 Kudos
21 Replies
RussellRoberts1
Esri Frequent Contributor

Can you check the services list of replicas made to see if that replica ID exists on the service?

You can see the list of replicas under the feature service URL after you end the Feature Server URL with /replicas

0 Kudos
TravisAnderson
Occasional Contributor

Russ,

I really appreciate the reply.

I think I figured out what you were asking me to do. I went and checked each layer/service replica. Each layer had a replica except for one I believe. But, a layer called "Repair" had two replicas, and one of them happened to be the same ID as contained in the error. How would I resolve that so I don't get the error? When you create/download an offline map, is that when AGOL creates the replica?

Thanks for the help!

0 Kudos
MiaogengZhang
Esri Regular Contributor

How often do you see this error? After downloading the map, you click sync button with nothing to sync. Will you see the error immediately or it happens sometimes? 

0 Kudos
TravisAnderson
Occasional Contributor

Any time I hit the sync button, whether I have something to sync or not, I get the replica error. It happens every time. Thanks for replying. I appreciate it.

0 Kudos
MiaogengZhang
Esri Regular Contributor

Can you share your map to a group and invite the account Collector4ArcGIS into it?  It could help us determine if it is service specific.

0 Kudos
TravisAnderson
Occasional Contributor

Miaogeng,

Would that only be shared with the ESRI Collector team and not the world? I have to be cautious with security since we are a water utility.

Thanks!

0 Kudos
RussellRoberts1
Esri Frequent Contributor

That content will only be shared with the Collector team. The collector account will get a notification that there has been a group invite and they can check out the map and the feature layers causing the sync issue.

Russ

0 Kudos
TravisAnderson
Occasional Contributor

Russell,

I created a group called "ESRI Collector Group" and sent an invite to Collector ArcGIS (Collector4ArcGIS). Hopefully I did everything correctly.

Thanks again,

Travis

0 Kudos
TravisAnderson
Occasional Contributor

I'm guessing it has something to do with the layer "REPAIR". There's nothing different with this layer compared to the rest that I know of. I deleted the original download and created another small offline map. When I sync back, whether adding anything or not, the error is the same as before in the above posted screen shot (Sync Error-Unable to synchronize replica.Sync replica internal error - {5b588d62-b55e-4ef2-9186-4bdbdff1b78e}

Below is taken from the ArcGIS REST Services Directory for the layer "REPAIR".

Replica Name: MyReplica_22, Replica ID: 5b588d62-b55e-4ef2-9186-4bdbdff1b78e

Replica Name: MyReplica_51, Replica ID: e5fca963-003e-4782-b3dd-9f076450c22f

Replica Name: MyReplica_65, Replica ID: ca81a6ce-35a4-4269-9d0a-12ab3bf77d16

I'm not sure I completely understand this, but when I create and download a tiled map can I assume that it creates a replica of the layers? Why would there be 3 Replicas? Maybe I should just delete this layer entirely from my map and re-upload it.  Is there anything I can use in the Supported Operations to delete the replica?  Query   Apply Edits   Create Replica   Synchronize Replica   Unregister Replica

0 Kudos