Samsung Galaxy Camera Attachment Issues

1977
7
05-28-2014 10:46 AM
CraigCheeseman
New Contributor III
I posted this earlier on another thread but realized that thread had been deemed resolved. This issue has not been resolved.

This issues seems to stem from the camera application using too much memory that it "steals" memory from Collector causing it to hang.

We just purchased a Galaxy Tab 4 8.0 inch model. I have made sure the OS is fully up to date and I have tried several Camera apps. When ever we collect a point and then add an attachment the app hangs where it shows the name of the map in the top bar and then just holds the data in edit mode. You have no way out. If you press the back button the app will ask you if you want to discard the point and even when I have gotten back to map view the point is highlighted and any touch of the screen moves the point to that location.

I have tested my map on a Droid DNA and a Nexus 7 tablet with absolutely no issues so this looks like a Samsung issue.

I do have an SD card in the tablet and I noticed that it stated that the SD would be used for storage and not the main drive. Could this cause the issue? I do not have external cards in either of the other two devices.

I thought I was good to go because I had tested fully on other devices and now I was getting ready for field deployment with our new gear and am now may be in real trouble. Any ideas are appreciated. Thanks.
Tags (2)
0 Kudos
7 Replies
PaulBarker
Esri Contributor
This is currently a known issue with some camera apps, the Collector team is looking into how we can work around this issue or mitigate it completely on our side.  In most cases this can be solved by switching to a different camera app , we've seen users work around it specifically with "Camera MX" or "Camera for Android"  from the play store. Other camera apps may work too but those are the ones we've seen work for Samsung devices exhibiting this problem.  If neither of those apps work for you please send us an email at Collector4ArcGIS@esri.com so we can get some more detailed information about the issue.

Regards,

Paul
0 Kudos
CraigCheeseman
New Contributor III
Thank you Paul.  Email will be on the way shortly.  I have tried those apps and more with no success.  Only workaround I have found is to take the photo, then collect the point and select the photo from the gallery.  Thanks.
0 Kudos
RickBoggs
New Contributor II
Is there any update to this issue? I'm running into it as well when using the Samsung Galaxy S5.

I haven't tried the workaround of capturing the picture first then attaching it via gallery rather then just capturing the picture when I collect a new point.

I'm a bit more worried about saving all of the data which is unable to be synced back online. If I deleted all of the pictures from each of the points would this allow the app to sync the edit back online?  -Edit-  I ended up backing up the photos and then deleting all of the attachments. The map will still not sync to ArcGIS Online.
0 Kudos
RussellRoberts1
Esri Frequent Contributor
This issue has been addressed and will be in our next update.

Russ
0 Kudos
RickBoggs
New Contributor II
This issue has been addressed and will be in our next update.

Russ


Any idea of the time frame for the next update?
0 Kudos
RussellRoberts1
Esri Frequent Contributor
We are aiming to have a release out before the UC.
0 Kudos
SeanO_Brien
New Contributor III
I was having the same issues as well with a Samsung Galaxy S4. I was able to save an attachment if I pulled it from my camera gallery. However, I could not take a picture within the app successfully. Downloading "Camera for Android" seems to have worked for now. Hopefully the update can address the issue.
0 Kudos