Pro to AGOL to Collector

1141
7
03-03-2018 09:40 PM
CharlotteSmith4
New Contributor II

I set up my Fields/Domains/Codes in Pro, then rt clicked the Feature Layer then "Share as Web Layer". In ArcGIS online I see the Hosted Feature Layer, Web Mapping Application and Service Definition. BUT nothing appears on my iPhone 6+  Collector App.  Obviously missed a step but I'm stumped.

Tags (2)
0 Kudos
7 Replies
XanderBakker
Esri Esteemed Contributor

Have a look at the steps provided here: Create and share a map for data collection—Collector for ArcGIS | ArcGIS and this help topic for if you want to go offline: Prepare maps for offline use—Collector for ArcGIS | ArcGIS 

0 Kudos
CharlotteSmith4
New Contributor II

Thank you for your reply... I've already worked through those tutorials as well as others in esri.com/training.   I have several Collector forms on my iPhone working perfectly.  I created those fields/domains/codes in ArcMap 10.5.  I'm thinking the issue is related to sharing / transferring the files from Pro to AGOL. 

0 Kudos
XanderBakker
Esri Esteemed Contributor

You used "Share as Web Layer", and that is the best way for doing it. You created a web map and added the layer and the features draw without problems in the web map? 

Make sure that in the settings of the hosted featurelayer:

You have the appropriate settings:

0 Kudos
CharlotteSmith4
New Contributor II

Attached is a screenshot. My settings were already similar to what you suggested.  I can see the Collector App that I created the fields/domains codes in ArcMap  (shared with the same group), so I'm thinking it's a Pro issue.  Thank you.

0 Kudos
XanderBakker
Esri Esteemed Contributor

Have you added the hosted feature layer to the web map with full editing permissions? When you open the web map in ArcGIS Online, you can edit the layer?

0 Kudos
CharlotteSmith4
New Contributor II

Isn’t that what the screen shot is showing?

0 Kudos
XanderBakker
Esri Esteemed Contributor

Hi Charlotte Smith , I though that when a feature layer is enabled for editing, it was possible to add it to a map without the editing capabilities, but it seems to enable them by default despite the way you add the hosted feature layer:

This only way to avoid it would be using a hosted feature layer view, but that's not what you want. I am going to CC KGerrow-esristaff‌, she knows a lot about this and might be able to point you in the right direction.

0 Kudos