Possible Bug - Text Field used for Symbology shows up as a domain field when editing

2020
20
Jump to solution
04-15-2014 01:29 PM
LuciHawkins
Occasional Contributor III
I have several text fields in my data.  All show up as text boxes when I go to edit a point EXCEPT for the one text field that I am using for symbology of the points.  When I edit that text field, it shows up like it is a "domain" or "subtype" and not a text field. 

Any ideas?

Thanks,

Luci
Tags (2)
0 Kudos
1 Solution

Accepted Solutions
LuciHawkins
Occasional Contributor III
I deleted the text field we were using for symbology and created a new field that uses a domain and the problems on the IOS device seem to have been rectified.  I don't know why but using that text field weirded out Collector on IOS.

Thanks,

Luci

View solution in original post

0 Kudos
20 Replies
RussellRoberts1
Esri Frequent Contributor
Are you using a 10.0 or 10.0.1 feature service?

Russ
0 Kudos
LuciHawkins
Occasional Contributor III
I am publishing the service from ArcGIS 10.1 SP1 for Desktop - Advanced, when I look at the rest service on ArcGIS.com it says:
{
  "currentVersion" : 10.21,
  "serviceDescription" : "StreetLight Project",
  "hasVersionedData" : false,
  "supportsDisconnectedEditing" : false,
  "hasStaticData" : false,
  "maxRecordCount" : 1000,
  "supportedQueryFormats" : "JSON",
  "capabilities" : "Create,Delete,Query,Update,Editing,Extract,Sync",
  "description" : "StreetLight Project",
  "copyrightText" : "",
  "spatialReference" : {
    "wkid" : 102660,
    "latestWkid" : 2238
  },


Thanks,

Luci
0 Kudos
RussellRoberts1
Esri Frequent Contributor
If possible could you share your service with me?

Thanks
Russ
0 Kudos
LuciHawkins
Occasional Contributor III
Hey Russ,

Invitation sent to join StreetLight editing group.

Thanks,

Luci
0 Kudos
RussellRoberts1
Esri Frequent Contributor
What fields are not displaying correctly for you?

Thanks
Russ
0 Kudos
LuciHawkins
Occasional Contributor III
The field:    Field_Verified   

When you go to edit a point, the field does not show up as a text box, instead you have options with check marks like it was a subtype field or a domain field.

We are using that field for symbology because we either want the symbol green or red.  Red (N - for No) means our people need to check the light in the field, green (Y - for Yes) means the light has been checked.

I think this must be by design because when I go to "add" a new item, it only gave me the option of adding a "N" feature.  I worked around the problem by entering "Y" in the field of one of our points.  Now we have the option of picking N or Y when editing and also a N or Y option when collecting a new feature.  I should have used a Short Integer with a domain yes/no instead of text. :)

Thanks,

Luci
0 Kudos
LuciHawkins
Occasional Contributor III
I shared a new service on ArcGIS Online.  I did not symbolize it in desktop, I used the symbology capabilities of the online map.  The first time we went to edit a point it showed up as a text box, which is what it is, text.  As soon as we saved the edited point, the field went back to a domain or pick list.  The other fields that are domains and had pick lists changed to text boxes.  This is only on the IOS devices.  If you go to the webmap and edit a point there, the fields that have domains still have pick lists.

Any ideas?

Luci
0 Kudos
RussellRoberts1
Esri Frequent Contributor
Can you share the link to the service with me and I can take a look at the data model.

Thanks
Russ
0 Kudos
LuciHawkins
Occasional Contributor III
Russ,

I believe you are still a member of our group and should be able to see it.

Thanks,

Luci
0 Kudos