No Results Found after changing Collector Geocoding Service

4002
9
Jump to solution
07-08-2015 11:58 AM
BenGrod
Regular Contributor

I changed the default Geocoding Service (Utility Service) on our ArcGIS Portal (10.3) to point at a service that we host on one of the Federated ArcGIS Servers for Portal. This new geocoding service works within a map in Portal and the directions Widget as well as locally within ArcMap but it doesn't work on Collector. I don't receive an error when searching in Collector for an address or location it just returns "No Results Found" for all/any search I attempt. I'm even searching simple specific names which should return a result. Anyone have trouble using a custom geocoding service in Collector? 

0 Kudos
1 Solution

Accepted Solutions
RussellRoberts1
Esri Frequent Contributor

Are you seeing this on iOS and Android? composite geocoders should work... if you do the same search through the REST endpoint or if you track the network on the search in AGOL look at the candidate match score and what is the value you see returned.

It will look something like this:

  1. candidates: [{address: "Redlands, California, United States",…}, {address: "Redlands, Colorado, United States",…},…]
    1. 0: {address: "Redlands, California, United States",…}
      1. address: "Redlands, California, United States"
      2. attributes: {Match_addr: "Redlands, California, United States", StAddr: "", City: ""}
      3. extent: {xmin: -13052938.324981114, ymin: 4026327.0588141317, xmax: -13036463.04034371,…}
      4. location: {x: -13044700.536611203, y: 4036265.6386144585}
      5. score: 100

Russ

View solution in original post

9 Replies
NickSkinner
New Contributor II

I have had the same issue within Collector as well as Explorer for ArcGIS.  Not sure if its just not compatible with custom address locators?

RussellRoberts1
Esri Frequent Contributor

Is the geocoding item that is being used in your portal shared to the entire portal and not just to the Admin account?

BenGrod
Regular Contributor

Hey Russell,

It is shared to everyone on the portal, both via the sharing properties on ArcServer Manager and the Portal interface. I have a ticket in with Esri Support and the first (email) question they had for me was is it a Composite Locator. I responded that yes it is a Composite Address Locator but they haven't replied back. Would this be the issue, does Collector not cooperate with Composite Address Locators?

Thanks much for your help, as always

0 Kudos
RussellRoberts1
Esri Frequent Contributor

Are you seeing this on iOS and Android? composite geocoders should work... if you do the same search through the REST endpoint or if you track the network on the search in AGOL look at the candidate match score and what is the value you see returned.

It will look something like this:

  1. candidates: [{address: "Redlands, California, United States",…}, {address: "Redlands, Colorado, United States",…},…]
    1. 0: {address: "Redlands, California, United States",…}
      1. address: "Redlands, California, United States"
      2. attributes: {Match_addr: "Redlands, California, United States", StAddr: "", City: ""}
      3. extent: {xmin: -13052938.324981114, ymin: 4026327.0588141317, xmax: -13036463.04034371,…}
      4. location: {x: -13044700.536611203, y: 4036265.6386144585}
      5. score: 100

Russ

View solution in original post

BenGrod
Regular Contributor

Thanks Russ, hadn't done that yet, I'll check out your suggestion. Also, I'm on an iPhone 5, iOS 8.3, Collector 10.3.1 and Portal for ArcGIS 10.3.1

0 Kudos
BenGrod
Regular Contributor

Okay, I did some more testing. Not search I am doing exactly what you asked but I tested the rest endpoint "Find Address Candidates" from the iPhone and successfully used the locator via the browser (Safari). It located a feature called Batt 1. I also searched for addresses successfully. Interesting that the rest endpoint for "Geocode Addresses" returns "Unable to complete operation" but the "Find Address Candidates" works successfully. Screen shots below of the results.

Results from Find Address Candidates (same result on iPhone as on desktop)

IMG_0010.PNG

Results from Geocode Addresses (same result on iPhone as on desktop)

IMG_0011.PNG

0 Kudos
BenGrod
Regular Contributor

Update. Esri Support help me to test the correct URL that Collector hits when searching for address. It actually hits "Find" as opposed to the "Geocode Address" or "Find Address Candidates" which are both accessible as Supported Operations links from the geocoding service. Below is a example URL with find tagged on to the end. This URL needs to be tested successfully from the desktop and from the mobile device web browser.

https://servername/arcgis/rest/services/LocatorName/GeocodeServer/find

I was able to test this URL for our geocoder on both the desktop and mobile device, however Collector was still returning No Results Found. As an additional test I logged out of Collector and logged in with my full user name (ben.grod@companydomain.com). The geocoding service then correctly returned results in Collector. Before I was logging in with just my user (ben.grod), we are still trying to determine if it was the user name or something else but in the mean time things are working.

0 Kudos
NathanEnge
Esri Contributor

are you able to take your custom geocoder offline with collector?

MiaogengZhang
Esri Regular Contributor

Collector doesn't support offline custom coder.

In some sense, feature search is similar to geocoder. Collector support offline feature search