Last_Edited_Date (and time) is off by 7 hours?

2517
2
Jump to solution
10-09-2015 03:12 PM
VenusScott
Occasional Contributor III

When entering or editing data with collector, we are encountering a problem where the "time" portion of the record is 7 hours off?

Oracle record:

The actual time this record was edited was at 2:50pm (Arizona time)

I verified the device date and time were correct . . .

I verified the ArcGIS Server date and time were correct . . .

Our DBA swears the database date and time are correct . . .

Where else could this erroneous time be coming from?

0 Kudos
1 Solution

Accepted Solutions
AsrujitSengupta
Regular Contributor III

I guess that is a case of UTC vs Database Time.

Which one did you choose while enabling Editor Tracking?

Enabling and managing editor tracking—Help | ArcGIS for Desktop

To enable editor tracking with your own field names or to record times in database time, you need to use the dataset's Properties dialog box or the Enable Editor Tracking geoprocessing tool. The Enable Editor Tracking tool allows you to add new fields and enable editor tracking on those fields at the same time.

View solution in original post

2 Replies
AsrujitSengupta
Regular Contributor III

I guess that is a case of UTC vs Database Time.

Which one did you choose while enabling Editor Tracking?

Enabling and managing editor tracking—Help | ArcGIS for Desktop

To enable editor tracking with your own field names or to record times in database time, you need to use the dataset's Properties dialog box or the Enable Editor Tracking geoprocessing tool. The Enable Editor Tracking tool allows you to add new fields and enable editor tracking on those fields at the same time.

VenusScott
Occasional Contributor III

That was it! I guess by default it uses UTC?

Thank you!

0 Kudos