How long will it take for a new web app to appear in Collector?

1201
9
02-03-2017 03:20 AM
AnthonyCheesman1
Occasional Contributor II

Hello 

I've just started experimenting with Web apps and Collector. I have created my first web app today (very basic map viewer containing 2 published services).

The app works fine on my PC but is not yet visible in Collector (after 8 hours).

Should there be a delay between app creation / publication and visibility in Collector, have I missed a crucial step, or is something amiss?

I've checked all the simple stuff that I can (web map created in same account Collector is logged in as etc etc).

Has anyone else experienced this issue?

Thanks

0 Kudos
9 Replies
PeteCrosier
Occasional Contributor III

Do you have an editable layer in your web map? It should be visible in Collector as soon as you save the map in AGOL and then refresh in Collector.

AnthonyCheesman1
Occasional Contributor II

No - all layers at this point are read only.

I do need to create a service for data collection - I'll do this on Monday when I'm back at work and see if that resolves the issue.

Is an editable layer a requirement for a web map to be available in Collector? If I think about it, I suppose the name *does* give it away.

PeteCrosier
Occasional Contributor III

Yep, you must have an editable layer for a map to show up in Collector.

AnthonyCheesman1
Occasional Contributor II

As a postscript to this, re-created my project with an editable data collection service and it was available in the app immediately.

Thanks for the help!

CarmelConnolly3
Occasional Contributor II

Have you tried signing out and back into the app? Sometimes I've found I've had to to this for a web map to appear.

Carmel

AnthonyCheesman1
Occasional Contributor II

Yes I did try that - unfortunately it didn't resolve the issue.

0 Kudos
ChristopherMcClain
Occasional Contributor II

When you use the term "web app" do you really men web map.  Collector consumes published web maps not applications.  But the web map should be available as soon as published in AGOL.  Possible sticking points can be how the data and map are shared.  Also what type of device are you running collector on make sure you have internet connectivity and that collector is up to date.  If all of this checks out try forcing a stop on the app and reopening as this might force a refresh.  On thing I have seen is that on MS surfaces sometimes the app will not connect to the internet even though the tablet has connectivity.  I only have one of these and don't really use it that much so I haven't spent any time looking into the reason.

Chris M

AnthonyCheesman1
Occasional Contributor II

Yes - it was a web map I created. I'm still getting used to all the terminology! I'm running Collector on iPad Air 2 with latest firmware and I assume latest version of Collector. Have tried manually killing app and forcing a reload etc etc. 

Based on a suggestion above, I'm thinking the issue is the lack of a editable layer, so I'll check that first / rule out as a cause before I get too concerned.

0 Kudos
JohnMartineau
New Contributor

I had the same problem. I clicked "save" in the web map and the collector map appeared within seconds.

0 Kudos