Data remaining in Downloaded Collector Maps after changes to attributes that are filtered

907
3
Jump to solution
08-08-2017 06:24 PM
MPC_KineticGIS_Department
Occasional Contributor

The basic premise of what we are working on is that we have a large amount of dynamic data and it is filtered to only display design data that is approved for Construction. This design changes regularly and swaps between approved and unapproved based on changes to site conditions and construction requirements.

To achieve this is a simple definition query in which a field Status is set to one of three options, Proposed, Current, and Archived. This is the same principle we have been using for years with the ESRI suite of products. To keep the Construction teams isolated from building unapproved or old designs query is set up so that data is only shown on any map they see to Status = Current.

In downloaded maps in collector if a feature is changed from current to anything else the features remain in Arc Collector as current until the map is removed and re-downloaded again. During a sync the data is never updated or removed from the originally downloaded data.

This behaviour is not the same behaviour that occurs in normal replicas or versions, this only occurs in offline maps in collector. What is the point of the sync functionality if it only does half of the job. I would have expected that any features that are removed from the map from a change in attribution by a layer query would also be removed from any downloaded maps after a synchronisation occurs?

Does anyone have a work around solution for this type of replication management in a disconnected environment?

We are now looking at other options to solve this as I can see no logical way of solving the issue.

We have tried Definition queries in the service layer within ArcGIS Server.

Filters within the Published map in ArcOnline.

I should also mention that this works perfectly in where a feature is changed to current but not when it is changed from current to something else. At a function level it looks like the adds table is functioning correctly but the delete table is not being referenced in the child replica as the feature is filtered out.

0 Kudos
1 Solution

Accepted Solutions
NielsVemmelund1
New Contributor III

In my opinion this looks lige a bug - based on your description.

The behaviour should be consistent regardless of which application interprets the data.

This 'feature' potentially invalidates some of the intended backend - field worker workflows, for which Collector is designed.

View solution in original post

3 Replies
JakeSkinner
Esri Esteemed Contributor

Hello,

I was able to reproduce this behavior Collector for ArcGIS version 17.0.2, build 1028 on Android.  I would recommend contacting Tech Support to log this issue.  It appears this may be a bug.  The tech support analyst can log this and then development will be aware and can start implementing a fix for a later release.

MPC_KineticGIS_Department
Occasional Contributor

I have but apparently it is working as intended and as such no bug was created, I completely disagree with that statement.

Once the analyst understood the issue, he discussed the issue with his team, and has advised that although there were numerous changes with the new update of ArcGIS Online in June 2017, the behaviour you have reported is the expected behaviour of Collector.
No bug has been logged for this behaviour.

0 Kudos
NielsVemmelund1
New Contributor III

In my opinion this looks lige a bug - based on your description.

The behaviour should be consistent regardless of which application interprets the data.

This 'feature' potentially invalidates some of the intended backend - field worker workflows, for which Collector is designed.