Collector is creating bogus "Ags" versions in SDE

1259
1
02-19-2016 06:35 AM
MarkLund
New Contributor III

I’m having a problem with my versions being created while downloading a map.  I have a secured service named “Water” used by field staff for editing water valves and hydrants.  It is part of our core SDE database and the service is published off of a ‘WaterMaint’ version under the QC.  When a staff member downloads the map for use a version is then created capturing their credentials and then the service name.  I have the service set as a “sync” service for offline editing and the advanced option is set to Sync on User.  I have a post/reconcile script that runs nightly to sync up each version with each other.  Everything seems to be fine for a few days and then all of the sudden I get a new version in my database named “Ags_Fs_1454331744313_44993”.  These versions are showing up as a "child" to a user version that Collector created previously.  Now when the staff member goes to sync he is either getting an error message and it won't allow him to sync or his edits go to this "Ags" version which is not accounted for in our nightly script since we don't know it exists.  How and why are these versions happening?  Has anyone else experienced anything like this?

Tags (1)
0 Kudos
1 Reply
DonnaRiebe
New Contributor III

I have just started seeing this occur.  Our setup is the same as yours, secured service hitting our SDE, individual versions for each user hitting collector.  I also have an auto reconcile script that runs nightly.  We are having occasional sync errors, but they do not seem to be related to this issue.

0 Kudos