Collector for ArcGIS not compatible with Android 6?

4664
15
Jump to solution
11-13-2017 01:58 AM
Nicole_Ueberschär
Esri Regular Contributor

We just tried to install Collector for ArcGIS on one of our office smartphones, a HUAWEI with Android 6. When we try to download from the Google App Store it shows the message "not compatible with your device". 

I just checked for the requirements on the Collector webpage and it says from Android 4.2.

Did someone else faced this issue? 

I find this error message not very helpful. Does someone know if this comes from the google side or if this is something configured with the app so it could be improved from the Esri side?

Thanks in advance for your feedback!

1 Solution

Accepted Solutions
Kylie
by Esri Regular Contributor
Esri Regular Contributor

We've found that Google Play is incorrectly reporting that some compatible devices are not compatible. There is a workaround: you can install Collector directly from Esri by following the steps in FAQ: How do I download Collector for ArcGIS without access to Google Play or the Windows Store?

View solution in original post

15 Replies
PeteCrosier
Occasional Contributor III

I believe the developer sets the requirements that a device must meet to use their app, then Google checks the developer requirements vs. the devices registered to a user to decide if they can install an app or not. Android 6 should be fine with Collector, but it could be that the specific Huawei device you're using doesn't meet some other requirement. Which Huawei is it?

Nicole_Ueberschär
Esri Regular Contributor

Thank you Pete! 

It would be helpful if the GoogleStore would give some more information why it is not compatible...

Here is all information about the phone. Does it tell you anything why it actually is not compatible?

About information HUAWEI

0 Kudos
PeteCrosier
Occasional Contributor III

It looks like a reasonably powerful and fairly recent device - I think you'd need to pass on the device specs to Esri support to see if they can check them against the full list of requirements they've specified.

0 Kudos
Nicole_Ueberschär
Esri Regular Contributor

Thanks Pete, I will do so...

0 Kudos
MarkUnwin
New Contributor II

I would suspect ESRI recently changed the specs for installing this app.  I used to have this installed on my phone, and had to uninstall if for space reasons, and now can't reinstall it.  No answers why, just speculation here so far.

0 Kudos
MarkUnwin
New Contributor II

I emailed the contact on the play store with this question  collector4arcgis@esri.com

0 Kudos
NavaSheer
Occasional Contributor

I have the same issue - used to work, took it off for space issue and now is longer compatible (while on an older tablet its still  fine).  Did you get any replies from the collector people?

0 Kudos
Nicole_Ueberschär
Esri Regular Contributor

I got this response from Esri support but couldn't test it yet because the mentioned phone has other issues now... But maybe it helps you to resolve the problem: 

The version of the OpenGL should be OpenGL ES 2.0. You can check it with following apps:

https://play.google.com/store/apps/details?id=littledreamstudios.openglcheck&hl=en

https://play.google.com/store/apps/details?id=com.realtechvr.glview&hl=en

If the version is not 2.0 this is the cause of the error message in the google store. 

(Don't know though if this is something that can be resolved...)

0 Kudos
PeteCrosier
Occasional Contributor III

The specs I can find online say that your phone should support OpenGL ES 2.0, so it would be interesting to see what those apps report.

0 Kudos