Collector feature disappearing when zoomed

666
6
Jump to solution
09-11-2017 06:50 AM
StuartMoore
Occasional Contributor III

Help,

   we have just started to experience an issue with collector that wasn't their last week.

we have a map to allow users to update a set of assets and their attributes and then to record a survey using a related feature class, both stored in ArcGIS online, since the weekend (as far as i can tell) when you zoom in below 50m the two feature class's disappear, but other features don't...

has anyone else experienced this, i know their have been no changes to the scale ranges, could it be the ArcGIS Online database spatial indices are corrupt?

thanks

Stu

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
RandyBurton
MVP Regular Contributor

You might try updating the definition so that minScale is 0. But you should be able to override this setting with the visibility range when you create a map in AGOL. 

I've played around with this setting on one of my layers, but I haven't been able to duplicate your situation.

View solution in original post

6 Replies
RandyBurton
MVP Regular Contributor

Open your map in ArcGIS Online and check the visibility settings on the layers you are having issues with.  There are two settings: the zoom level for them to show up and the zoom level for them to disappear.  It is the second that appears to be causing the problem.  Try setting it to "room", and then resave your map and refresh it in Collector.

0 Kudos
StuartMoore
Occasional Contributor III

thanks for the reply Randy, i have checked and it is set to the lowest scale which In my case is buildings, I have checked some other layers any they too are set to the same scale but they stay visible but the others disappear....

very odd

Stu 

0 Kudos
RandyBurton
MVP Regular Contributor

When you look at the layer's json file, what are the values of "minScale" and "maxScale"?

0 Kudos
StuartMoore
Occasional Contributor III

the JSON for the layer shows the min/max as below:

"minScale" : 5000,
  "maxScale" : 0,

this match's the other layers that are still visible when this one disappears

0 Kudos
RandyBurton
MVP Regular Contributor

You might try updating the definition so that minScale is 0. But you should be able to override this setting with the visibility range when you create a map in AGOL. 

I've played around with this setting on one of my layers, but I haven't been able to duplicate your situation.

StuartMoore
Occasional Contributor III

thanks again for the reply, so we managed to get it working, it was the scale range in the feature service that was at fault, the max had changed (not sure how) to 2500. I only noticed after I went back and checked, it looked like the server had cached the settings so once I changed them I then refreshed the service and it worked for some of the users.

But it didn't work for all of the users it looked like the old settings had been cached also on the users devices, to resolve this the user had to delete and re-install collector or the other solution that worked was to save a copy of the map but with a different name.

thanks again for the help