Collector - cannot take map offline on Android- error in creating runtime geodatabase

4600
5
Jump to solution
04-28-2015 01:27 PM
MarkHoover1
New Contributor II

I recently created a file gdb with relationships and pushed it into AGO.  I have had success using the map in IOS and Android and been able to use all of the relationship functionality in the field.   However when I try to take it offline on my android I get the following message

"The map '...' failed to download with the message: Unable to create replica. Please check your parameters., Error in creating runtime geodatabase."

It works fine on any IOS and I was successfully able to take other maps offline on my android that had simple feature services.  I know there have been numerous posts on this topic but I still cannot seem to find the answer.  I am on 10.3 in both collector and ArcGIS.

Thanks

Mark

0 Kudos
1 Solution

Accepted Solutions
ScottPrindle
Esri Regular Contributor

The release should be live in the App Store and Google Play now. They were made available earlier this week. Please be sure to reply on this thread if this issue or any similar issues with related tables continues to happen, as we would like to investigate these concerns.

Thanks,

Scott

View solution in original post

0 Kudos
5 Replies
MiaogengZhang
Esri Regular Contributor

Mark, in Collector Android, if you have one feature service with one feature layer without related table and another feature layer with a related table. You will see the same error message. The workaround would be

1. Publish the feature service with only one feature layer and relationship class table for editing.

2. Publish a second service with the remaining feature layers.

Or if you add the same layer with related table twice into your webmap, the error will happen as well.

This issue will be fixed in the coming release.

DavinShokes1
Occasional Contributor

Has the this release occurred? I'm still getting the issue with a related table in the web map.

0 Kudos
ScottPrindle
Esri Regular Contributor

The release should be live in the App Store and Google Play now. They were made available earlier this week. Please be sure to reply on this thread if this issue or any similar issues with related tables continues to happen, as we would like to investigate these concerns.

Thanks,

Scott

View solution in original post

0 Kudos
BertKraan1
Occasional Contributor III

This afternoon I had the same issue on IOS and Android after an 'update feature definition' operation to add some bird species to a domain. It turned out one of my ID's "Code" was not unique. Fixed that and all is well.

Hope this help someone.

Bert

SamanthaNichols1
New Contributor II

Bert, you are a lifesaver! I spent several hours searching Google and Geonet trying to resolve this issue, and it was the same error. I had duplicated one of my domains. Deleted it out and updated the definition again and it worked! Thank you, thank you, thank you!

I was getting the error "Unable to create replica. Please check your parameters. Error in creating runtime geodatabase." Hopefully that will help others searching for this error.

-Samantha

0 Kudos