Can't change name of rest service when creating a new record.

366
6
07-17-2018 07:52 PM
LauraMawhinney
New Contributor III

I am using collector in android with multiple hosted feature services.  When the user clicks on the plus sign to add a new record the screen displays the name of the rest service.  For example - devsde.LMAWHIN1.PILOT_GPS_HYDRANT.  Attached is a screen shot of what I am talking about.  I would like change this to "GPS HYDRANT."  I have update the name the name in the contents but this doesn't change it.  How can the name be changed?

All comments and answers are welcome.

0 Kudos
6 Replies
CarmelConnolly
Regular Contributor

Hi Laura, 

How were these feature services created in the first place? Published from ArcMap/ArcGIS Pro?

Are the layers hosted in ArcGIS Online or ArcGIS Enterprise?

You may need to go back and rename the layers in the table of contents then republish them.

Another option would be to change the JSON of the feature service through the REST end point: https://www.esri.com/arcgis-blog/wp-content/uploads/2014/10/How-to-Update-Hosted-Feature-Service-Sch... 

I would say that this is something that could negatively affect the layer and if you were to try it, do it on a test feature service first. 

Carmel

0 Kudos
LauraMawhinney
New Contributor III

Hi Carmel,

These are hosted feature services published from ArcGIS Pro to portal.  It seems that part of the publishing process is adding the sde database name "dev" and my user name "lmawhin1" in front of the rest service name.. If I rename the layer in portal in the contents afterwards it doesn't carry over to the display in data collector.   This information is not need for the user experience and makes it hard to read. 

I looked at the link and documentation,  Although you can change field properties, domains and their values, template details and max record count, I didn't see anything about the name of the rest services itself.  I wish that I could.

Laura

0 Kudos
CarmelConnolly
Regular Contributor

Hi Laura, 

Ah if you're publishing to Portal, that document won't work as it's for Online specifically.

If you change the layer name in the Table of Contents, you'll need to over write or publish from scratch for the change to carry over. 

Carmel

0 Kudos
LauraMawhinney
New Contributor III

Hi Carmel,

Thank you for this information. 

Laura

0 Kudos
LauraMawhinney
New Contributor III

Hi Carmel,

I received tried again and it worked.  I am not sure what happened the first time, but it is working now. 

Thank you!

Laura

LauraMawhinney
New Contributor III

Hi Carmel,

I tried your suggestion of renaming.  It is still shows the sde name and user prefixed before the name in the table of contents.

Laura

0 Kudos