Attachments in Collector will not sync, numerous devices

2810
3
06-27-2014 08:49 AM
ThomasColson
MVP Frequent Contributor
I have a working collector App on through my organization AGOL account. A simple point feature class. Works great in desktop, AGOL, etc, including adding attachments (photos). Works great on numerous mobile devices in collector, as well. Can record a new point, synch, edit delete points, synch, add 10 points, synch.

It all fails when I add a photo attachment. Add a new point with attachment, will not synch. Edit a point and add attachment. Will not synch. Photos are about 2.5 mb. Of course it fails with a very informative error message:
Sync Error a Error occurred while synchronizing edits. Operation rolled back.

1st Device: Iphone 4s, IOS 7.1
2nd Device: Garmin Monterra Android version 4.0.4

On the iphone, if I go back an edit the point and delete the attachment, it will then sync.

On the monterra, even if I go back and delete the points that had the attachments, it will not synch. In other words, on collector for android, even if you remove whatever edit is causing a sync to fail, you're screwed. Just lost your days worth of data collection.
Tags (2)
0 Kudos
3 Replies
ThomasColson
MVP Frequent Contributor
...removed Editor Tracking from the FGDB and republished....same error.
0 Kudos
ThomasColson
MVP Frequent Contributor
...added globalID to the feature class....republished....seems to work now
0 Kudos
Cameron_Smith
New Contributor II

I am having a similar issue, unless I use the disconnected editing feature with my iphone 4s, I am not having the issue from android, still need to test on iphone 5

0 Kudos