AGOL maps not showing in Collector App

28588
30
10-11-2013 01:29 PM
KenMcDonald
New Contributor II
Okay, so I have spent the last few days trying to figure out why the Collector App, will not load any of the maps that are stored in
AGOL. I have confirmed that all the files are created correctly as per every piece of documentation posted on the entire internet.

Therefore I have come the conclusion that the App is buggy in some form. YES, I'm using a Point only, editable feature service and
they all worked a few months back when I first tested the Collector App.

There are a few posts on this forum that refer to my conclusion because they have resorted to either re installing the App,
changing account passwords and/or changing ownership to the feature service.

I also administer another AGOL account in which they are using the Collector App without a problem. Nothing has been added, changed or manipulated for at least 5 months. I created the editable point feature services the same way I do currently. In other words, I have not done anything to this particular account, and the Collector App works fine.

So...I now ask, is it possible that someone can give me a step by step fix for the real issue or even a conformation of the issue and
a fix is in the works?

Any help would be greatly appreciated!

Ken McDonald
Tags (2)
30 Replies
NilsRatnaweera
New Contributor III

Hey Russ

Almost exactly one year later, I'm experiancing the same problem. I have a map application with a host feature service that is editable for my AGOL group.

I was able to view and edit it with the Collector App, but when by mistake I removed the editing capabilities and later readded them to the hosted feature layer, the map disapeared permenantly from the app. Any ideas for solutions?

EDIT: It seems there ws n issue with concerning the rights on the hosted feature layers. Some layers were open to everybody, others were only for a certain group. I've recreted the app and now it works!

JuanPeralta1
New Contributor III

I was experiencing the same problem.

I think If you add a Hosted Feature Layer (with no editing capabilities) to a WebMap and then make it editable it will never be available from Collector (no matter whether it is editable or not). First you have to make the layer editable, and then add it to the WebMap, from that moment it will be available in Collector. At least it worked for me.

MiaogengZhang
Esri Regular Contributor

Juan,

If you add a Hosted Feature Layer (with no editing capabilities) to a WebMap and then make it editable, you need to re-save the webmap again to recognize the change of Hosted feature layer.

-Miaogeng

BertKraan1
Occasional Contributor III

Thanks! This solved an issue here!

the people who wrote this software should be ashamed! I'm glad their victims gather here for some comfort. (I may sound a bit grumpy but this has costed me a week worth of expensive engineer.)

KevinRohling2
New Contributor

I also had this problem, thanks!

0 Kudos
BrianFausel
Occasional Contributor III

This is still a thing in Spring 2018, and Miaogeng's solution was the fix for me as well.

0 Kudos
LouiePadilla1
New Contributor II

Hi Brian,

Unfortunately it is still a thing.. I actually am dealing with this now. How did you get yours fixed? I’m not seeing the maps at all or the layer wasn’t found in arc collector. You could however view it in a web map. Strange... it was supposed to be a quick creation of a field collection map but ended up taking most of my time.  Any suggestions are helpful! 

BrianFausel
Occasional Contributor III

In the case I encountered here, I added a hosted feature layer (initially not set to be editable) to a web map. Then, I changed the hosted feature layer settings to be editable. After doing that, the web map still did not show up in Collector. I found this thread, so then I went back into the web map and simply did a Save. Then, the web map showed up in Collector.

Another (slightly unrelated) thing you might have to do is share the web map with an AGOL group that includes the Collector user in the group. Having a web map that is stored in AGOL but not shared with a group will result in it not showing in Collector.

KarenCarr
New Contributor III

I only had to change the users to publishers and create a group with the map and the users in the group and it finally worked. New install of Portal. thanks very much for the info.

0 Kudos
MollyWatson1
Occasional Contributor

I have a feature layer that is is hosted through AGOL and set to editable. The feature layer was created as results from Survey123. I tried adding the feature layer to a brand new AGOL map and saving the map, but the map does not show up in Collector. I tried saving a copy of the map with the layer and it still does not show up in Collector. I tried deleting the Collector app and re-downloading. The map still does not display in Collector. I am trying to integrate Survey123, Workforce, and Collector. It appears there is a disconnect with the web map created from Workforce to Collector, even though I have them linked through the settings in Workforce.  All layers and maps are shared with a group, that I (the collector) am part of. Does anyone have any other suggestions on how to get the AGOL map to display in Collector?