Strange ItemID Behavior When Launching Survey123 From Feature Popup In Collector

693
2
08-14-2020 10:09 PM
MachielVan
New Contributor
0 2 693

I published a survey to my organization's ArcGIS Online portal, then configured a custom popup in an associated web map to launch the survey from the popup of a polygon feature class. 

 

At first, I used the ItemID supplied by the REST endpoint, but that caused an "Unpacking Error" in the field app at first, then it failed to find the survey and returned a message regarding the ItemID being unknown. 

 

When I checked the Survey123 webapp Collaborate section for the auto-generated Share url, I noticed the ItemID associated with the survey was completely different from the one supplied by the REST endpoint. Is this normal? 

 

The good thing about this dynamic is that the share url seems to remain constant even if the survey is deleted and republished, so the launch-from-popup functionality is preserved. 

 

I just think it's odd that the ItemID in the share url differs from the REST endpoint, and if that's the case, how are the two ID's related??

 

-MV

2 Comments
ClayDonaldsonSWCA
Occasional Contributor

Survey123 can be made up of 3 itemIDs:

  • The form item which is used to access the form in Survey123 field app (form item id)
  • The feature service where the data is stored (feature service item id)
  • A view of the feature service is created when you use the collaborate pane. usually generated with "_stakeholder" suffix (feature service view item id)

That view is used for controlling how the feature service displays in the Survey123 Data/Analysis page.

If you are trying to open survey123 from a pop-up, you would use the form item id.

MachielVan
New Contributor

This makes complete sense. Thank you Clay. Launching Survey123 in this manner is extremely useful for projects that require the accumulation of thousands of photo attachments so the Collector maps stay small and easily downloadable.