Roof orientation - does CityEngine forget?

1887
4
08-30-2013 01:11 AM
BenLeslie1
Regular Contributor
Hi

I have drawn 440 building footprints in CityEngine.  I have taken care with the edge I have drawn first to help me control the orientation of gable and shed roofs.  In case I have made a mistake with the first edge I have added a 'roofIndex' attribute so I can change the orientation of the roof where necessary.

I have found that when I re-open the project some of the roofs have changed their orientation since I saved the file - I'm not sure how many buildings have changed because the effect is mainly quite subtle but in the case of long-thin buildings with a shed roof the effect is very obvious because the roof becomes enormous.

Is this a known problem (2011.2)?
Does CityEngine forget which edge was drawn first?
Does it forget the change to my 'roofIndex' parameter? 
Would it remember the first edge better if I used imported shapefiles?
Could I be doing something wrong?

It's very difficult for me to spot a pattern to this because it's difficult to be sure where it is happening.
0 Kudos
4 Replies
MatthiasBuehler1
Frequent Contributor II
Hi Ben,


Can you test this with an installation of the CityEngine 2012 TRIAL ?

I'm not perfectly sure if this was a specific 2011 bug.

Can you track this down to a very simple rule and 1 building which reproduces the issue ?

Let me know.

matt
0 Kudos
BenLeslie1
Regular Contributor

Can you test this with an installation of the CityEngine 2012 TRIAL ?


I'm afraid I'm not getting CE 2012 trial to work - it just hangs on the splash-screen.

I think I meet minimum system requirements...I have:
Windows XP Professional x64 Service Pack 2.
NVIDIA Quadro 2000

I've rebooted since I installed it.....any suggestions?
(The machine on which I have 2011.2 installed is not connected to the internet so I trying to install this on a different one).
0 Kudos
BenLeslie1
Regular Contributor

I have found that when I re-open the project some of the roofs have changed their orientation since I saved the file - I'm not sure how many buildings have changed because the effect is mainly quite subtle but in the case of long-thin buildings with a shed roof the effect is very obvious because the roof becomes enormous.

Could I be doing something wrong?


I'm sorry, I forgot I was mucking about with the convexify command at the beginning of my cga file......it's all my fault.

This thread can be deleted if you like.
0 Kudos
MatthiasBuehler1
Frequent Contributor II
Hi,

this could be a few things..

please write to support@esri.com , ok ?

m.
0 Kudos