"Washed-out" CityEngine scene

918
6
11-18-2016 11:12 AM
JimWooten
New Contributor III

I created and area of interest in ArcMap and then copied and pasted the files into the map folder for a new project in City Engine.  When the image appeared it looks "washed-out' (see the attachment of the image in ArcMap on top and then the image after importing into CityEngine).  Any suggestions on what went wrong?  Thanks.

Jim

0 Kudos
6 Replies
JimWooten
New Contributor III

It appears to be a resolution issue.  CityEngine is downsampling the texture resolution (to 214 X 150) regardless of the resolution of the original texture image created in ArcMap.  The original resolution of the image was 7032 X 4927.  I downsized that image to 4000 X 4000, copied and pasted the files into CityEngine and used it for the scene.  Again, the resolution was downsampled to 214 X 150.  I tried again going down to 2000 X 2000 and got the same result.  Is there a way to turn off the auto-downsampling feature in CityEngine?  Thanks for any help.

Jim

ThomasFuchs
Esri Regular Contributor

Hello Jim,

There is no down-sampling of terrain textures in CityEngine. Higher-End graphics hardware should be able to hold textures in the size of the original resolution. Could it be that 214 x 150 is the resolution of the DEM?

Regarding the washed out look of the texture, could it be that the Aerial.tif is sampled in 16 bit? CityEngine simply maps such terrain textures down to 8bit. So as a best practice, one creates first an contrast enhanced 8bit image from 16 bit high dynamic range images.

0 Kudos
JimWooten
New Contributor III

Hi Thomas:

I did find this link: https://community.esri.com/thread/48433

that states that "higher resolution textures may be downsampled automatically by CityEngine ( for viewport display only ! )."  I will try to create the 8bit image first.  Thanks.

Jim

0 Kudos
CherylLau
Esri Regular Contributor

Yes, higher resolution textures may be downsampled but only if they are above the max texture sizes set in the Edit -> Preferences window.

0 Kudos
CherylLau
Esri Regular Contributor

A resolution of 214 x 150 is small and seems a bit strange to be a default.  You can check the max texture size here:  Edit -> Preferences -> General -> Procedural Runtime -> Max texture height, Max texture width.  I think the default is 2048.

0 Kudos
JimWooten
New Contributor III

Hi Cheryl;

Yes, my default is also set at 2048.  Thanks.

Jim

0 Kudos