How to tweak Redlands Redevelopment Rule (v2015) to visualize single family development?

2446
4
10-19-2015 08:31 AM
JacobPetrosky
New Contributor III

Any ideas on how to modify Redlands Redevelopment Rule (v2015) to (A) eliminate hardscape (pathways) in rear yards and/or (B) specify maximum building footprint in a cga rule (Redlands Redev. or other)?  See the attached image for the problems.  You will see around A there is pathways in the rear yard that is unrealistic, specifying unit width in the rule has no effect.  In B in the attached image you will see that on some parcels buildings are created that are long and not reflective of proposed single family condition. 

4 Replies
by Anonymous User
Not applicable

Jacob,

Attached are mods of three rules that will give two new options for GreenSpaceType:

- Lawn

- Lawn with trees.

Also fixed was a bug where parts of the formal garden did not produce a ground texture.

I can't help with your second problem, Sorry!

Instructions: Download attached zip file. 3 rules are inside.

1. Backup your entire project. Specifically the 3 rules you will replace.

2. Replace the three files in your project with the ones in the zip file:

     - Greenspace Construction is in main folder with other rules.

     - The other two rules go in the Support folder beneath.

If this breaks things, or doesn't work, come back to this post. You may have to go into each file, and insert a space into some line of white space, to force the CGA files to recompile. Or remove CGB files from bin folder if you have bin exposed.

Chris

0 Kudos
JacobPetrosky
New Contributor III

Chris,

I still get only Formal and Natural for Green_Space_Type after I replaced the rule files as instructed.  Let me know if I need to recompile or something.  Thanks!

Jake

0 Kudos
by Anonymous User
Not applicable

Hi Jacob,

I'm sorry the changes are not working for you, I'll look and make sure I packaged the updates correctly. But in any case, if you would be like to be a fearless CGA explorer, then try using the Inspect Model mode with the Model Hierarchy window open. Click on the hardscape in the yard in your model. It will show you a node in the Hierarchy window. Double click the node for the hardscape, and it should take you to that part of the rule. Figure out how to bypass displaying the hardscape texture and replace with the yard texture, or just reroute the flow of the CGA to send that sidewalk into a Yard rule, or whatever it is called (I can't recall the name).

Chris

0 Kudos
JacobPetrosky
New Contributor III

Thanks Chris.  I was able to get something that worked for me, although it is not as elegant as I would have liked.  I placed the Lawn 2.jpg in the assets\3D_City_Design_Assets\Material_Library\BlocksPavers\ folder.  Then I changed the rule to:

HardscapeStep2 -->

    case texturingOn:

        setupProjection(0, scope.xz, 5*Pathway_Scale, 5*Pathway_Scale) projectUV(0)

        texture(materialDirectory + "BlocksPavers/" + "Lawn 2.jpg")

        #texture(materialDirectory + "BlocksPavers/" + Pathway_Type + ".jpg")

        HardscapeStep3

    else: HardscapeStep3

This removes the hardscape and matches the lawn.  You can still see a difference.  Something with the spacing on the pathway scale that is not quite right maybe.  But for largescale perspectives it is ok.  Would like to have a lawn option in the hardscape dropdown if there is way.  Right now the rule is just hardcoded to override the hardscape, which could get confusing if I forget. 

I saw what you did to the rule--adding cases to the FrontYard option, but for some reason it is not working in the dropdown.

0 Kudos