How to prevent creases from being added into buildings

08-08-2016 11:36 AM
New Contributor


I''m working on a landscape model of my university campus and have a bunch of buildings for both the campus and the surrounding area. Here is what the model looks like:

area buildings.png

Unfortunately though, I'm having an issue where the roofs of my buildings have creases in them for some reason. In the CityEngine viewport, they look fine, but when I bring it into a web scene, the creases are pretty noticeable. Does anyone know how to deal with an issue like this? I'm trying to make all the buildings uniformly flat on the roofs. Here is a closer look at what the building creases look like:

building creases.png

0 Kudos
1 Reply
Occasional Contributor III

As far as I can tell from the screenshot you apparently aligned the footprints onto the terrain using projection. This moves their vertices seperately, resulting in twisted footprints. Either use the translate option or try extrude(world.up.flatTop, yourHeight).

0 Kudos