HOW TO export CityEngine model to sketchup and lumion?

8742
10
12-16-2013 12:36 PM
MilosMandic
New Contributor
Hi,

I'm having trouble importing my CityEngine model into sketchup.
Can anyone show me correct export parameters for sketchup? When I try to import .kml I get no results, and when I try to import .dae sketchup just stops working. I don't know what the problem is.
Also I'm trying to do the same thing with Lumion, so if anyone knows how, I would be grateful.
I want my material and textures to be kept after import.

Thanks in advance!

Milos
Tags (2)
0 Kudos
10 Replies
MatthiasBuehler1
Frequent Contributor II
Hi,


This could be many things ..

I need more details to give some input on this.

Do you get some errors in the Log Window ?


Is the dataset georeferenced ?

Let me know ..

matt
0 Kudos
MilosMandic
New Contributor
Hi matt,

I had a problem with the model being georeferenced, but I solved that. I just set the global offset to 0,0,0 when exporting.
When I import the model into sketchup as .dae the geometry is pretty messed up.
When I import a kml file:
1) if compressed file - then only one shape gets imported
2) when not compressed - then I have to import one model at a time. And because i have previously made the model centered, evry model gets imported at zero coordinates of the coordinate system (I get all models on the same place, not according to their mutual position in cityengine)
I hope I'm being clear enough since English is not my first language.
0 Kudos
MatthiasBuehler1
Frequent Contributor II
Hi,


When using 0,0,0 as offset, you KEEP the georeferencing data. you need to press the center button to center all near the cartesian origin. using 0,0,0 stores very large coordinate values, thus the 3d display runs into precision issues. Thus, the models look broken.

What other export settings are you using ? Are you exporting one model per shape ?

Maybe a few screenshots would be very helpful ..

Let me know ..

matt
0 Kudos
MilosMandic
New Contributor
[ATTACH=CONFIG]29941[/ATTACH]

I select multiple models generated on dynamic lots.
If I press center on the Global offset then I cant even import the file into sketchup.
If I leave it as 0,0,0 than it imports to Cartesian origin in sketchup but the model is broken.

So in shgort: the models are georeferenced, I want to export a whole block (multiple models) to sketchup, eather as .dae or .kml (what option is better?). What settings are recomended?
0 Kudos
MatthiasBuehler1
Frequent Contributor II
Hmm ..


One other question .. (sry for the many questions)
Are you using CE 2012 or CE 2013 ?

If not 2013, try that one too, ok ?

matt
0 Kudos
MilosMandic
New Contributor
I'm using CE2012.
0 Kudos
MatthiasBuehler1
Frequent Contributor II
ok, please try 2013 then. Just download the TRIAL version. It'll work with the 2012 license.


http://www.esri.com/apps/Products/CityEngine2/index.cfm

matt
0 Kudos
ElliotHartley
Occasional Contributor
If you can get it into SketchUp but the model looks messed up (as it's too far from the origin) I have used this tool in SketchUp before called MoveToOrigin (it's free).   You probably need to double click on the imported component select all and then run the tool....)

It helps me sometimes :)

All the best

Elliot
0 Kudos
GucluSen
New Contributor
Hi,

I've used to export ".3ws" often for publishing the model so far.
I have just tried to use CE export operations about different formats but I haven't succeeded yet.
I tried to export ".obj" file format. I opened Blender 3D and result is;
[ATTACH=CONFIG]30035[/ATTACH]

My 3D Models is not available with this form.
Can I export the model with its texture and without any corruption? Or shall I work with Blender or Studio Max etc. with model for looking good.
0 Kudos