Edit collada (.dae) files in CityEngine or ArcGIS Pro?

3931
4
09-21-2015 08:38 AM
ScottAulen2
New Contributor III

I'm looking for a workflow to be able to make edits to collada files within CityEngine or ArcGIS Pro.  Currently we receive collada files from proposed developments that we incorporate into CityEngine and then use in the application process.  Often the proposed models need a few edits to ensure they fit the proposed site and context appropriately. 

I've had success bringing the collada files into CityEngine as a static model and exporting them out as multipatch files (which can then be brought in and edited in CityEngine) but doing this loses the texture attributes.  If I bring the collada model in as a dynamic model for editing, the textures are lost as well.

My attempts in ArcGIS Pro have been confusing and unsuccessful.  The model usually comes in completely flat.

Does anyone have a proposed workflow for this?  I'd really like to not have to resort to a third party application (Sketchup, Blender, Meshlab, etc.) but will if I have to.

0 Kudos
4 Replies
LeonardoCarvallo2
New Contributor II

I understand, I also had problems with the properties the export it, but Sketchup try and I kept the textures, the issue is quite simple and with many options, it cumbersome to work with several programs but in my case I have worked, good luck!!

0 Kudos
DeepinderDeol
New Contributor III

Here are some options in ArcGIS Pro:

1. You can use the Import 3D Files GP tool to bring your DAE models into a multipatch feature class. Please refer to this help topic on the GP tool: Import 3D Files—Help | ArcGIS for Desktop

2. You can also use COLLADA models to symbolize point features, make the required symbol edits and then you could export out to a multipatch feature class using the Layer 3D to Feature Class GP tool - Layer 3D To Feature Class—Help | ArcGIS for Desktop - note that if you save the output as a shapefile then textures will be lost. So you should save output as a gdb feature class.

Once you have the multipatch feature class, you can edit (move, rotate, scale etc.) the features in ArcGIS Pro.

Thanks.

ScottAulen2
New Contributor III

Deepinder,

Thanks for your response.  I've tried both approaches and have been unsuccessful.

1. You can use the Import 3D Files GP tool to bring your DAE models into a multipatch feature class. Please refer to this help topic on the GP tool: Import 3D Files—Help | ArcGIS for Desktop

     I've tried this approach a number of times and I've never been able to get something to work.  I don't get an error with the GP tool but either a.) nothing shows up or b.) the model is imported but it's completely flat (see attachment 1 for how it looks in ArcGIS Pro and attachment 2 for how it looks in City Engine; exact same file).  I've tried different settings on the GP tool but the results are always the same.  

2. You can also use COLLADA models to symbolize point features, make the required symbol edits and then you could export out to a multipatch feature class using the Layer 3D to Feature Class GP tool - Layer 3D To Feature Class—Help | ArcGIS for Desktop - note that if you save the output as a shapefile then textures will be lost. So you should save output as a gdb feature class.

     The problem here I believe is that the models are fairly complex (between 200,000 to 5 million polygons) and so when symbolizing the point, ArcMap just bogs down and becomes unresponsive.

  

   

0 Kudos
DeepinderDeol
New Contributor III

Hi Scott,

The model is flat probably because you chose the current scene coordinate system as the coordinate system for the output multipatch feature class AND the current scene's coordinate system was GCS WGS 1984. To avoid this issue choose another coordinate system (like UTM etc.) - if you have other existing data for your scene then you can determine which coordinate system to use from this data.

Also please look into the option of using placement points for proper positioning of the imported models  - this might help as well but I think the flat models problem should be resolved with an appropriate coordinate system setting.

Thanks.

0 Kudos