CityEngine 2019.1 scene freezes after turning shadows on, have to relaunch CE

1141
2
Jump to solution
02-16-2020 03:55 AM
LessieOC
New Contributor III

I am thrilled to be using the new version. I had created the project in #CE 2015.2 and imported it into #CE 2019.1 It seems to works fine: create scenarios and edit shapes, etc. Yet, when I turn on shadow or ambient inclusion, the viewport/scene_freezes.

First,  I loaded the old project I into a new workspace (in D drive) and when launching the scene, I would get some errors (log view1). I then imported the project into the default workspace (in C drive) and the errors cleared (log view2).

In either case, turning shadow or inclusion freezes the scene and I have to re-launch CE to resume with no shadows. 

Any advise on how to make shadows work will much appreciated. I am attaching pics of logs and settings, if of any help.

0 Kudos
1 Solution

Accepted Solutions
LessieOC
New Contributor III

Dear Taisha, 

Thank you for your response. The laserlines and viewsheds worked. New smaller scenes also worked. In looking for the GPU information, I run into Graphic settings and after setting the Graphic performance preference to High performance for  cityengine 2019 exe, the scene freezing went away. It looks like the default #gpu performance settings were just not helping. 

View solution in original post

2 Replies
TaishaFabricius
Esri Contributor

Hi Lessie

To help to troubleshoot this, can you please let us know the following:

  • Do laserlines work (e.g. in the Measurement Tool)?
  • Do Viewsheds work?
  • Can we get the machine specs? (especially the GPU spec)

Thanks a lot

Taisha

LessieOC
New Contributor III

Dear Taisha, 

Thank you for your response. The laserlines and viewsheds worked. New smaller scenes also worked. In looking for the GPU information, I run into Graphic settings and after setting the Graphic performance preference to High performance for  cityengine 2019 exe, the scene freezing went away. It looks like the default #gpu performance settings were just not helping.