Webmap Version Not Supported

869
3
08-14-2017 08:32 AM
MarkBenson
New Contributor

To Whom it May Concern,

Good morning, Recently I downloaded AppStudio and AppStudio AppStudio Player, for ArcGIS. I'm trying to evaluate this software for my company which produces and sells seeds to commercial farms. In the Studio i'm running ArcGIS Runtime 100.1.0. Appstudio for ArcGIS is version 2.0. I can download my test map to both my phone and my desktop but when I go to run the map on either the desktop or my phone, I get an error that says "Webmap not supported, pre 2.0. Veriosn 1.9". I'm assuming that means i'm running version 1.9 for the Appstudio Player. Is there a way to update this version? It's probably something simple that i'm just not seeing, however, I'm just learning how to use this software and any help I can get would be appreciated, thank you.

Sincerely,

Mark Scott Benson

Tags (1)
0 Kudos
3 Replies
nakulmanocha
Esri Regular Contributor

Your AppStudio version is up-to date.

Cause: The issue you are seeing is because ArcGIS Runtime 100.1.0 only supports webmaps 2.0 or higher.

Solution:-

Case:1 If the webmap you are using belongs to you. All you have to do log in to arcgis.com and open the webmap in arcgisonline and a do a save. This will update the webmap version and it should start working in your app without any further issues.

OR

Case:2 If the webmap doesn't belong to you you might be able to do a "Save As" in your org. This will give you the same webmap under a new webmap id. Just copy the webmap id and put it in your application and update your app in the Player. 

I hope this helps.

Nakul

0 Kudos
MarkBenson
New Contributor

Dear Nakul,

Good afternoon I wanted to respond to your e-mail and thank you for the advice you gave me. Unfortunately it did not work. I logged on to ArcGIS and went to my app that i created on my laptop, and tried to update, save, and down my app again. When i ran it, on both the desktop and the phone, I still got the same error through the App Player. The actual error message i get is. "Webmap version is not supported. Pre Webmap 2.0 is not supported. Version: 1.9. I should back up and mention that I did not see any place to save it on ArcGIS Online or ArcGIS for Developers. I could only update and download it again, which I did. I should also mention that this is my own map that I created. I am not apart of any organization and therefore have not shared this app with anyone else, although that's something I might try to see if that fixes the issue. Is there anything else you think i should try? Any other advice you could give me would be helpful. I would like to get this working before I test it with any of the company's maps. Thank you.

Sincerely,

Mark Scott Benson

0 Kudos
nakulmanocha
Esri Regular Contributor

This issue is not related to your app. It is about the webmap. Since this is your webmap. Please log in to the arcgis online and load the webmap. The webmap urls look like this (6cfeb10019644ad38e4dd21eda658c28  is the webmap id). You need to save this map again.

http://appstudio.maps.arcgis.com/home/webmap/viewer.html?webmap=6cfeb10019644ad38e4dd21eda658c28 

May I ask you when was this webmap created?

If you need further help with webmap please log a new ticket with the esri support team. They should be able to guide you further on how to approach this.

Nakul

0 Kudos