Not able to use services from tiledbasemaps.arcgis.com in Quick Reporter

163
5
Jump to solution
03-30-2020 07:49 AM
BrentSlone3
New Contributor III

We are using AppStudio for ArcGIS Desktop version 4.2.80.

We were looking forward to add custom functionality to download basemap as tpk on fly. 

We added services from tiledbasemaps.arcgis.com as basemap in our public webmap. However, the webmap does not load in the quick report application when launch it. 

It is important for us to make this work with services from tiledbasemaps.arcgis.com since these services are enabled with export tiles enabled and that would be used with ExportTileCacheTask

We were able to run the sample with basemap: World_Street_Map (MapServer) 

Is there any configuration in AppStudio for accessing services from tiledbasemaps.arcgis.com as basemap?

Or is this an expected behavior?

0 Kudos
1 Solution

Accepted Solutions
ErwinSoekianto
Esri Regular Contributor

Brent, 

I just tested the workflow you described above using this service as basemap, https://tiledbasemaps.arcgis.com/arcgis/rest/services/Elevation/World_Hillshade/MapServer, and yes I can reproduce the same issue you described. 

This is expected since this service is not a public layer, you need to login using ArcGIS account to access it, and Quick Report only supports public webmap as outlined in the setting page. 

We can make this work, by adding custom code to the source code of Quick Report template to include the credential to access the webmap as outlined in this doc, Access the ArcGIS platform—ArcGIS Runtime SDK for Qt | ArcGIS for Developers. We can add it in QuickReport/pages/RefineLocationPage.qml around line ~247

I tested this and I was able to load the webmap that contains the service from tiledbasemap.arcgis.com as basemap. 

Thank you, 

Erwin. 

View solution in original post

5 Replies
ErwinSoekianto
Esri Regular Contributor

Brent, 

I just tested the workflow you described above using this service as basemap, https://tiledbasemaps.arcgis.com/arcgis/rest/services/Elevation/World_Hillshade/MapServer, and yes I can reproduce the same issue you described. 

This is expected since this service is not a public layer, you need to login using ArcGIS account to access it, and Quick Report only supports public webmap as outlined in the setting page. 

We can make this work, by adding custom code to the source code of Quick Report template to include the credential to access the webmap as outlined in this doc, Access the ArcGIS platform—ArcGIS Runtime SDK for Qt | ArcGIS for Developers. We can add it in QuickReport/pages/RefineLocationPage.qml around line ~247

I tested this and I was able to load the webmap that contains the service from tiledbasemap.arcgis.com as basemap. 

Thank you, 

Erwin. 

View solution in original post

BrentSlone3
New Contributor III

Thank you for the prompt response! 

I was able to run this with ArcGIS online Credentials. 

Is it necessary to configure the Credentials with ArcGIS online credentials? I tried adding our Portal for ArcGIS url and credentials. It did not work.  

0 Kudos
ErwinSoekianto
Esri Regular Contributor

I am glad to head that. 

For tiledbasemap.arcgis.com you need to use ArcGIS Online credentials, but if you want to use other premium tiled services from your Portal, then you would use that Portal credentials. 

0 Kudos
BrentSlone3
New Contributor III

Can you please share links on premium tiled services in Portal?

0 Kudos
ErwinSoekianto
Esri Regular Contributor

I think for Portal, you would need to publish them on your own, and you would know the URL.https://enterprise.arcgis.com/en/portal/10.4/use/publish-tiles.htm 

This is more of a concept, where tiledbasemap.arcgis.com is not a public item and requires ArcGIS Online credentials, and you would need Portal credentials to access non-public items from Portal. 

0 Kudos