Import statement unable to load some modules

310
3
Jump to solution
12-03-2017 10:22 AM
MervynLotter
Regular Contributor

Hi there

I am a newby to AppStudio and while working through the Load a Web Map and Display Device Location tutorial, I noticed that one of the modules did not import. It is the: import QtGraphicalEffects 1.0 module. See attached image'

I am running "AppStudio for ArcGIS 2.1.19"  on Windows 10. I first noticed this problem running an earlier version (2.1.15) but tried updating to see whether that would fix the problem, but did not.

I have noticed that this module has failed to import in other apps I am playing/working with.

0 Kudos
1 Solution

Accepted Solutions
nakulmanocha
Esri Regular Contributor

Hi Mervyn,

Thanks for posting your issue. This is a known issue with Qt 5.8 and Qt 5.9.1. We are hoping to get this fixed with 5.10 release.

Thanks,

Nakul

View solution in original post

3 Replies
nakulmanocha
Esri Regular Contributor

Hi Mervyn,

Thanks for posting your issue. This is a known issue with Qt 5.8 and Qt 5.9.1. We are hoping to get this fixed with 5.10 release.

Thanks,

Nakul

MervynLotter
Regular Contributor

Hi Nakul

Thank you for reply. Will Qt 5.10 be released with AppStudio 2.2 or earlier. Or any idea when we can expect Qt 5.10?

Regards

Mervyn

0 Kudos
nakulmanocha
Esri Regular Contributor

Yes we are planning to release AppStudio 2.2 with Qt 5.10. But it is early days and 5.10 is not released yet so can't be 100% sure at this time. Plus I don't know if this known issue do get resolved with the 5.10 final release.

Nakul

0 Kudos