Error when playing Map Viewer template Appstudio.arcgis.com

3188
9
Jump to solution
09-17-2015 09:21 AM
NathanEnge
Esri Contributor

Hi. It seems that after the most recent update to appstudio.arcgis.com I am getting error when playing any new app using the Map Viewer template from appstudio.arcgis.com

I am referencing this publicly available web map with an editable hosted feature service: http://www.arcgis.com/home/webmap/viewer.html?webmap=bb0fd3c35496431991674aebf628a29b

and I get the following error when playing in AppStudio player on iPhone and iPad (deleted and redownloaded the app player as well from iTunes)

This error from iPAD 2

9-17-2015 9-18-02 AM.png

This same error in iPhone 5 with iOS8

9-17-2015 9-19-47 AM.png

0 Kudos
1 Solution

Accepted Solutions
MarikaVertzonis
Esri Regular Contributor

Hi Siva

Unfortunately the map viewer issue relies on an updated version of AppPlayer for iOS. This has been sent the store and is pending release.

Regards, Marika

View solution in original post

0 Kudos
9 Replies
PaulHaakma
Regular Contributor

Hi Nathan

I was discussing this with Marika at Esri yesterday. In my case, it seems to have been to do with the import statements in my app.

The problem one for me was:

import QtQuick.Controls 1.4

It didn't like v1.4, changing them all to 1.3 made it work again.

I noted that the app still ran from the AppBuilder if they were 1.4, and also when natively compiled, just not through the App Player.

You could try checking your code for this statement or perhaps any other import statement that might be the cause. If the Map Viewer template itself has a problem then I guess either they will need to correct the import statement in the template or update/fix whatever is causing the App Player not to run it...

Cheers,

-Paul

SivaRameshSontineni
New Contributor

Hi Paul,

I am having the same issue but my QtQuick.Controls version shows as 1.1, Please help on this issue

Thanks

Siva

0 Kudos
MarikaVertzonis
Esri Regular Contributor

Hi Siva

Unfortunately the map viewer issue relies on an updated version of AppPlayer for iOS. This has been sent the store and is pending release.

Regards, Marika

0 Kudos
SivaRameshSontineni
New Contributor

Thanks for information Marika,

When can this be updated to store. Any idea ?

Thanks

Siva

0 Kudos
RebeccaStrauch__GISP
MVP Esteemed Contributor

Siva, for what it's worth, I got a notification for an update to AppStudio Player on my iPad last night.

0 Kudos
MarikaVertzonis
Esri Regular Contributor

Yes, the beta 4 version of player is now available in the iOS store.

MarikaVertzonis
Esri Regular Contributor

Hold that thought... there seems to be a problem with the version that is now in the ios store - we are working to fix this asap. Sorry for the delay. We will post when its sorted.

0 Kudos
ShobanaSuresh
Esri Contributor

Hi All,

The latest Beta 4 version of Player(Version 1.0.25 built using Qt5.5.0) is now available in the iOS app store.

Below issues are fixed now,

- Map Viewer apps work as expected without errors in Player

- Apps using "import QtQuick.Controls 1.4" work in App Player now

cc: Marika Vertzonis

Thanks

Shobana

NathanEnge
Esri Contributor

Thanks. Will give it a go in the morning.

Cheers

Sent from my iPhone

0 Kudos