Can not deliver app to Apple Store

325
4
Jump to solution
12-13-2018 07:20 AM
KamranYusaf1
New Contributor III

Hi,

I have created an app based on the quickreport template. When I want to deliver the app it is rejected because its built with an old SDK:

I have used the newest template available. Why is this happening?

0 Kudos
1 Solution

Accepted Solutions
ErwinSoekianto
Esri Regular Contributor

Kamran Yusaf

What version of AppStudio Desktop are you using to do Cloud Make with for this IPA file?

Thank you,

Erwin

View solution in original post

0 Kudos
4 Replies
ErwinSoekianto
Esri Regular Contributor

Kamran Yusaf

What version of AppStudio Desktop are you using to do Cloud Make with for this IPA file?

Thank you,

Erwin

0 Kudos
KamranYusaf1
New Contributor III

I was using 2.1. I didnt know that would have an impact when using cloud make. I used 3.2 and there is no problems now.

Thanks for the help:)

0 Kudos
ErwinSoekianto
Esri Regular Contributor

I am glad that it is working using the latest version of AppStudio for Desktop. 

Yes, the Cloud Make environment used is dependent on the version of the AppStudio Desktop, the Cloud Make is being called from.

In your case, AppStudio 2.1 Cloud Make environment is using Xcode 8 to build the IPA file for iOS, that is no longer supported by Apple. Watch out for a blog that is coming out very soon regarding this. 

0 Kudos