Apps loading on desktop but not player on phone and fuzzy images

94
3
06-14-2019 11:35 AM
Highlighted
New Contributor III

Good afternoon!

I have 2 apps that are causing some grief:

1) I made one using the Map Viewer template.  It works just fine in the AppStudio Player on the desktop.  However, when I try to view it on the phone, I can see the start screen, but when I go to open the map, it just has the wait circle forever and never loads the map.  What do I need to do to be able to see this one the phone?

2) I made one using the Map Tour template.  This one I can see on my phone just fine.  However, the images for each location in the list view are fuzzy!  The same image in the pop-up though is clear.  How do I make the list view have clear photos? (I attached examples).

Tags (3)
Reply
0 Kudos
3 Replies
Highlighted
Esri Regular Contributor

Hello Sarah, 

I apologize for the delay response, this slipped through the crack. 

1) Are you running this inside the AppStudio Player on the phone or using the built app? If this is inside the AppStudio Player, this should not happen, it should work in the desktop and on the phone inside the AppStudio Player. I have a feeling it might have something to do with WebMap that is being used, where it might not be accessible from the network which the phone is connected to. 

2) When a Story Map Map Tour is created, we need to provide the two fields for images: "thumb_url" and "pic_url", many "thumb_url" have poor resolution, which why it looks blurry on this case. 

If you have access, you can change the "thumb_url" in the Story Map Map Tour to a better resolution image, or you can go to the Setting of the Map Tour template in AppStudio to override the Thumbnail URL to use the "pic_url", see image below.

I hope this is helpful,

Erwin

Highlighted
New Contributor III

I am looking at both inside the AppStudio Player on the phone.  

For the one using the Map Viewer template, I made sure all the data, maps, and the application is public.  It still isn't getting past the load screen still however.

For the Map Tour - that mostly worked!!!  I can see all the updates in AppStudio player on the desktop, but not on my phone version.  None of the edits (I did other things too like change the name) are coming over to the phone AppStudio Player.  It says in the phone that I did update it yesterday though.

I deleted them and re downloaded them, and refreshed them and that still isn't working.  I even re downloaded the full AppStudio Player, and that didn't work either and everything is public.  Any ideas?

Reply
0 Kudos
Highlighted
Esri Regular Contributor

For MapViewer, are you in the position to share the webmap id that is being used for this issue? So that we can try to see what's wrong.

For MapTour, it sounds like you need to upload the app first from AppStudio Desktop, so that you can see the changes in AppStudio Player. 

Reply
0 Kudos