support with python 27

456
4
Jump to solution
12-31-2018 12:14 PM
MeghanKulkarni
New Contributor III

Hello ESRI Team,

 

I’m trying to get ArcGIS API for Python locally installed on my workstation. My workstation config is as follows:

 

  • Windows 64-bit OS
  • Python 27 (which comes along with ArcGIS 10.5.1)

 

I used the command prompt to navigate to Scripts directory C:\Python27\ArcGIS10.5\Scripts>

pip install arcgis

. I’m getting below error:

 

C:\Python27\ArcGIS10.5\Scripts>pip install arcgis

Collecting arcgis

  Using cached https://files.pythonhosted.org/packages/6e/e3/a0da48d939ac81ac11921a6cd386d98b5c75d75b633a7959d78ae4...

    Complete output from command python setup.py egg_info:

    running egg_info

    Running post-install...

    No handlers could be found for logger "root"

    C:\Python27\ArcGIS10.5\lib\site-packages\setuptools\dist.py:470: UserWarning: Normalizing '1.5.2-post1' to '1.5.2.post1'

      normalized_version,

    Traceback (most recent call last):

      File "<string>", line 1, in <module>

      File "c:\users\meghan~1.kul\appdata\local\temp\pip-install-uzcrw5\arcgis\setup.py", line 272, in <module>

        setup(**kwargs)

      File "C:\Python27\ArcGIS10.5\lib\site-packages\setuptools\__init__.py", line 143, in setup

        return distutils.core.setup(**attrs)

     File "C:\Python27\ArcGIS10.5\lib\distutils\core.py", line 151, in setup

        dist.run_commands()

      File "C:\Python27\ArcGIS10.5\lib\distutils\dist.py", line 953, in run_commands

        self.run_command(cmd)

      File "C:\Python27\ArcGIS10.5\lib\distutils\dist.py", line 972, in run_command

        cmd_obj.run()

      File "c:\users\meghan~1.kul\appdata\local\temp\pip-install-uzcrw5\arcgis\setup.py", line 120, in run

        super().run()

    TypeError: super() takes at least 1 argument (0 given)

 

    ----------------------------------------

Command "python setup.py egg_info" failed with error code 1 in c:\users\meghan~1.kul\appdata\local\temp\pip-install-uzcrw5\arcgis\

 

FYI: I have updated my setup tools. My question is that ArcGIS API for Python not supported with Python 27?

My Best,

Meghan Kulkarni

0 Kudos
1 Solution

Accepted Solutions
DanielUrbach
Occasional Contributor II

Hello Meghan,

The ArcGIS API for Python only supports the use of Python 3.5+.  Please see the system requirements page for the API:

System requirements | ArcGIS for Developers 

I hope this helps!

-Danny

View solution in original post

4 Replies
DanielUrbach
Occasional Contributor II

Hello Meghan,

The ArcGIS API for Python only supports the use of Python 3.5+.  Please see the system requirements page for the API:

System requirements | ArcGIS for Developers 

I hope this helps!

-Danny

View solution in original post

MeghanKulkarni
New Contributor III

Thanks, Danny. I have a follow-up question. I have installed ArcGIS 10.6.1. Python distribution I see is Python 27. Where can I find Python 3.5+ ?

Cheers,

Meghan Kulkarni

0 Kudos
JoshuaBixby
MVP Esteemed Contributor

Did you read Install and set up | ArcGIS for Developers, the page lists several options for installing Python 3.x distributions for use with ArcGIS API for Python.

0 Kudos
DanielUrbach
Occasional Contributor II

Meghan,

ArcGIS Server 10.6.1 comes with Python 2.7 as it is needed to use ArcPy which comes with Server.  In order to use the ArcGIS API for Python you will need to install Python 3.5+ on the system you plan on using the API from.  As Joshua mentioned, check out the documentation for the various ways to accomplish this.

-Danny

0 Kudos